Platform_profile changes back to balanced automatically

Hi,

I’m using Fedora 35 on my Thinkpad T490. It’s a few days old clean install.

When I try to change the performance mode to performance or power saver from balanced, after a while it automatically switches back to balanced.

$ cat ./sys/firmware/acpi/platform_profile
balanced
$ powerprofilesctl
performance:
Driver: platform_profile
Degraded: no

  • balanced:
    Driver: platform_profile

    power-saver:
    Driver: platform_profile

The time passing between I change it to performance, and when it changes back to balanced seems to be fully random. It varies from 2 sec to a couple of minutes.

I already reported it to power-profiles-daemon’s Gitlab, but after some investigation, seems like the issue is with the firmware.

Kernel version: 5.15.12-200.fc35.x86_64

kernel: thinkpad_acpi: ThinkPad ACPI Extras v0.26
kernel: thinkpad_acpi: http://ibm-acpi.sf.net/
kernel: thinkpad_acpi: ThinkPad BIOS N2IET97W (1.75 ), EC N2IHT40W
kernel: thinkpad_acpi: Lenovo ThinkPad T490, model 20N20009HV

No dnf updates available, and according to fwupdmgr I’m using the latest firmware for every device.

Which logs should I check to identify why it is always changing back?

Thanks.

If it is a firmware issue, it may not be in the logs.

Searching through jounalctl -b would probably be the first place to check.

1 Like

I no longer have a Thinkpad in order to check, but I seem to recall from long ago that there is a BIOS setting around power management where I had to allow the computer operating system to control those settings. Next time you’re rebooting you might want to look at the BIOS power management settings. My recollections are from more than 10 years ago so this could be a false memory on my part. Good luck

Thanks for both of your replies.

I can’t find anything like you mentioned in the BIOS settings.

Neither in journal, I watched it with the -f flag while changing to performance mode, and nothing got logged that can be connected to my issue.

Lenovo’s documentation for this laptop model focuses on the Windows operating system and provides only the briefest of mention of Linux, unfortunately. My recollection was that for some Thinkpad models, in the settings on this page, you could choose to let the operating system set the modes, or set them in the BIOS, disallowing the operating system’s attempts to set them through its own user interfaces. So if there is a menu choice for the modes and schemes that implies OS control, you want that. If there is no such setting, then I’m completely wrong.
I did notice that there have been some issues with some of the BIOS updates for the T490 that caused fans to stay on at 100%, other issues around performance. You may want to review those in the Lenovo user forums.
Good luck

You did not say whether you were having this issue on battery or on AC or both, but the image you posted clearly shows performance to be set to balanced when on the battery and maximum on AC. Thermal management is ‘balanced’ and speedstep is ‘battery optimized’.

This would indicate that bios may be overriding the OS settings.

I’m on AC at all times, including all the cases I described above.

:thinking: how about disable it all. Maybe with disabling, it will leave the power management to OS. My bios don’t have those kind of things (of course with different manufacture).

If your disabling it, please take attention to fan speed.

kernel.org - Intel(R) Speed Select Technology User Guide