Playback device not persistent across reboots on fresh Fedora 36 install

I’ve just installed Fedora 36 (KDE) on a system where I use the attached HDMI device as the default playback device. This setting isn’t persistent across reboots, at least not every time.

I’ve come across similar descriptions while googling the issue, but no actual solution. What can I do to make the playback device persistent across reboots?

As I’m new to Fedora, I’m not sure if there’s a terminal command I can run on login, which sets the output device.
Edit I’ve read elsewhere, that one could use pactl to set playback device. I have no pactl installed. I’ve set up an additional test system and install pactl, but with pactl list short sinks, doesn’t quite provide the same options as I have in the settings window for the playback devices.

As suggested elsewhere, this doesn’t seem to be a viable option for me:

pactl list short sinks
pactl get-default-sink
pactl set-default-sink <sink

I’ve been using the media chooser gnome extension and that’s consistently worked for me. Seems to remember my preference between when I’m docked at home, docked in the office, or at home as well.

Thanks for the feedback! I’m using KDE (Wayland) and wouldn’t want to switch to Gnome. Is there something like the media chooser for KDE or could I run the Gnome extension on my KDE session?

1 Like

Good question! I have a Kinoite instance in the office, but I’m not planning on going back to the office until some time next week, but if I can remember, I’ll check when I’m there.

1 Like

Thank you Scott! I’m not too familiar with Silverblue, but I reckon there might be quite a difference in behavior if you have an immutable core system.

Silverblue is the Gnome version. Kinoite is the KDE version. AFAIK, there shouldn’t be any difference between those and regular Fedora Linux for how pipewire, etc. works. I only brought it up because that’s the only KDE environment I myself currently have.

Does pavucontrol-qt work?

Thanks