Possible Firefox Nightly Sandboxing Issue

I’ve installed Firefox Nightly onto my fresh Fedora 33 install and am having a video playback issue, but since the issue doesn’t show up in the standard Firefox installed by Fedora nor the Brave Nightly I’ve installed via dnf & their repo, I’m wondering if it’s a sandboxing issue; that is, I’ve placed my Nightly install in /opt, chmod-ed, and chown-ed it appropriately, but I think I might be missing something.

Any suggestions on where to start would be greatly appreciated and thanks, in advance…

1 Like

Do you have more details about the issue?

Try to start firefox from a terminal and see if errors showing up.

This link my help you find more info’s:

1 Like

Thanks, @ilikelinux

Not sure what other details I could share; but, for example, this video never loads. No errors, no logs, no crashes.

Since this is a Nightly issue, most of those “fixes” don’t apply, but the suggestion to install firefox-x11 at one point makes me wonder if this is a Wayland issue; however, that doesn’t make much sense, since other browsers, even those installed outside the Fedora repos, load the videos properly.

I’m still wondering if this is related to all of the sandboxing I’ve read up about…

I installed the nightly Firefox in a VM and got the same issue.
Fact is that in the plugin section of Firefox :

OpenH264 Video Codec provided by Cisco Systems, Inc.
This plugin is automatically installed by Mozilla to comply with the WebRTC specification and to enable WebRTC calls with devices that require the H.264 video codec. Visit https://www.openh264.org/ to view the codec source code and learn more about the implementation.

OpenH264 Video Codec provided by Cisco Systems, Inc. will be installed shortly.

not is installed !

1 Like

Didn’t even think to check plugins, @ilikelinux; thanks for that idea!

So, although the OpenH264 codec is properly installed on my system, the Nightly codec is located with the executable—/opt in my case—and it doesn’t use the “regular” Firefox installed codec; that is, if I use the Firefox installed with Fedora 33, I can play the video just fine, but it won’t play on my Nightly.

That makes me 100 percent certain it’s that sandboxing issue I referenced; any ideas about that?

For anyone who stumbles upon this, it took the better part of three hours to “refigure out” how I “fixed” this in F33 when I installed F34; essentially, I needed to enable the RPM Fusion repos and install additional media codecs:

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm

sudo dnf install https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

sudo dnf groupupdate multimedia --setop="install_weak_deps=False" --exclude=PackageKit-gstreamer-plugin

sudo dnf groupupdate sound-and-video

2 Likes