Prestige 14Evo A11MO | Speakers go to "Sleep" when no audio is being played

First time making a post my bad if i make a mistake. This issue happened to me on every single distro I have used on this Laptop (Prestige 14Evo A11MO). So whenever there is nothing playing the speaker go to sleep and then come back to life once a video/audio starts playing but even if there is no audio for one second the laptop speakers turn off instantly. In the video i placed here (https://sharex.itsduel.com/sIXO6/PoWoBEqu75.mov/raw) (This is TechHut and the yt video: you NEED this tool in Windows 11 (RIGHT NOW) - YouTube) when the video starts it says “lo everybody” instead of Hello everybody".

Welcome to ask.fedora @dueel

hmmm…

No problem, did you have a look at #start-here before posting? If not please have a look there to se what kind of information we need to help or try to help you.

A inxi -Fzxin terminal would be a good start to see what kind of hardware and drivers your system uses. Please post the information as preformated </> text here.

I just checked your device on MSI website and see that it is not a really Linux friendly (W10 & W11) device.
MSI Global - The Leading Brand in High-end Gaming & Professional Creation

I did take a quick glance at it.

I put it into a hastebin because its too big but here you go: inxi -Fzx output
Also sorry for the late reply

Nobara release 36

Please check with them first.

I have and it seemed to be a software issue and also as I stated earlier it happened in every distro including Fedora 36/37 Live ISOs. And since its a fedora “spin” I asked here.

It is not a Fedora Spin, it is a own Distribution with own kernel changes.

Which power profile are you using? Perfomance, balanced or power saver? did you check other options?

Check also in your bios if you have audio specific settings like noise canceling and or power-saving and switch them off.

Check with windows and install the newest bios inclusive the drivers you have on the website. If you still have the problem it is a hardware issue. And then you have to check with msi.

My bad on my part. But here on out I will use the fedora ISO I have to fix this issue there first.

Happens on all Power Profiles.

Will check and make sure there isn’t any but I do not think there is any like so. (Edit: Just checked and try to turn off anything with sleep/hibernate but it didn’t work)

On windows its completely fine.

Audio:
  Device-1 Intel Tiger Lake-LP Smart Sound Audio vendor Micro-Star MSI
  driver sof-audio-pci-intel-tgl bus-ID 00:1f.3

Seams to be having difficulties as many others too with sof-audio-pci-intel-tgl.
Did you install it manually or was it installed automatically?

At least your audio works many other don’t have sound at all.

It was installed automatically

I might try to reinstall the sof-firmware (IDK how if you can tell me a way it would be helpful) but other than that I do not know what to do.