Prevent screen from turning black when locked

I would like my screen to stay illuminated when locked. That way it can serve as a clock and it looks more bright than a black hole on my desk.
I have found this thread about using a gnome extension to achieve that, but I am completely clueless about making my own gnome extension and loading it. Does someone know where to copy the files and enable them?

I am not particularly picky about the method, so if someone has a better idea than the gnome extension then please share.

You should be able to set that in gnome settings → privacy → Screen Lock.

I have not tried it, but it appears that you can set the blank screen to never and the screen lock on a timer so it leaves the screen illuminated. Then you should be able to set the background of the locked screen to something of your choice.

It appears you can set the background for the locked screen with gnome settings → Appearance. I did that with gnome 3, but have not done that with gnome 41 or 42.

2 Likes

Thanks for the info. I tried it, but I guess it only affects automatic screen locking. When I manually lock my screen, then it automatically turns black. I can than manually wake it up again and with your trick in settings → Privacy → Screen Lock I can keep it on for one hour. But it would still be nice if it would not turn off after manually locking the screen.

I tried what I suggested on fedora 36 with gnome 42. My settings are shown
Screenshot from 2022-04-25 20-46-34
After waiting the minute for the lock to activate the screen darkened, but the clock remained active in the center of the screen. I let it set for about 10 minutes and the clock was still active and displayed when I came back to unlock the screen again.

I don’t know how to display a background or to have the clock move and prevent potential burn-in on the screen while the screen is locked.

I will check it overnight tonight to see if the clock is still displayed after several hours with the screen locked.

1 Like

BTW, you can select an image to be displayed when the screen is locked with gnome tweaks → appearance but when I tried it the selected image was not displayed. I suspect it is not properly configured with gnome 41 & 42.

Thanks for sharing your settings. I have set the same settings on my fedora 35, but now it even refuses to automatically lock the screen at all. 2 reboots ago it worked though… Anyways, having set the timeout to 1 hour now keeps the screen active when I manually lock it and press any key to prevent it from going black.
So I would not call it solved, but have a good enough workaround for now. Maybe I should try a fresh install when Fedora 36 is released.

Hi All. I appear to be having the same issue. When I lock the screen it shows the clock for a few seconds and then the screen goes black. I would prefer to have either a clock or screensaver running rather than the screen going dark.

I have tried the suggestions on this thread, but its not working in my case. Many many times after the screen goes dark and when I come back after 30 minutes or an hour I can’t get the computer to wake up, so I end up rebooting the machine 2 or 3 times a day, sometimes 4.

I am running a AMD Radeon 580x card. When i run the ‘lspci -v’ command, it reports that it is using the ‘amdgpu’ kernal, so I believe I have the latest drivers, but not sure.

Anything else anyone can suggest I try?

Thanks in advance for your help.

Maybe give Unblank lock screen - GNOME Shell Extensions

a try.