Printing issues in the different Fedora flavors

I have a question about printing in Fedora. Why is it different in getting a printer to work in the different DEs, specifically in Gnome versus KDE? I’ve used both extensively and, in all cases, have found that Gnome seems to find and use printers much easier than KDE?
Example: I recently setup a cups server running on AlamaLinux 8 on Raspberry Pi with a Brother HL-L2340D connected via USB. In Fedora Workstation with KDE I had to install printer-driver-brlaser in order to get the correct PPD driver when I added the printer. But even then it didn’t work. The print job was sent to the printer queue but it just sat in the print queue and never printed. However, when using Gnome it discovered the printer automatically without me having to actually add it and it seemed to install the correct driver because I was able to print, it did not sit in the queue and I didn’t have to install printer-driver-brlaser.

I would think that no matter the DE that at the core Fedora would not behave differently, no matter the DE. Is this not the case? If this is not the case, what is different in the DE development that handles printing differently?

Thanks in advance.

1 Like

CUPS (Commun Unix Printing System) is included in most (all?) Linux distributions, so that is included, no matter the DE.

I guess there might be different drivers loaded in KDE or Gnome? Or maybe one has a utility that automatically searches for the right driver? I’m interested in this answer too.


Were these in the same Fedora Linux release? Did you fresh install each time?

CUPS is available everywhere, yes, but different DEs have different configuration tools that may vary in their features and so on. The KDE printer setting and Gnome settings for printing are completely different, even if ultimately though go through CUPS.

Next, the different DEs pull in different sets of packages for their live images because their dependency trees are different. So it’s possible that the Gnome image pulls in the driver required for your printer but KDE does not.

It’s hard to say tbh without knowing what the issue with the KDE printing was—given that you installed the driver and it still didn’t work…

So I tried Fedora 35 & 36 with KDE and Fedora 36 with Gnome.
However, I want to state that in past Fedora versions with Gnome have always been flawless with printers. Separate from Fedora, for the heck of it, I also tried the latest version of Pop!_OS that uses the Gnome framework also had no issues with the printer.
I guess it makes sense Gnome developers have some type of mechanism to pull in the drivers.