Problem adding OpenVPN profiles through Gnome settings after upgrading to Fedora 32

Hi everyone.

Note: There is a duplicate answer here; but the solution didn’t work and the replies there are discontinued and blocked. So, I’m creating this new thread. For more information, read on.

I’ve upgraded my Fedora system to version 32 about last month ago. Almost everything is fine, but I have a problem while adding OpenVPN profiles through Gnome settings (i.e. GUI).

Note that, the problem is not with the profile itself, as it works with openvpn command. However, it’s frustrating to repeat the VPN connection task through Terminal.

Let me provide more details on the problem: The main thing is about adding the VPN, and specifically, the RSA private key not being saved. What happens is, when I import OpenVPN profile in Network section of Gnome settings, everything will be imported successfully but the private key file; it is being shown as “(None)”. The problem persists when I select the key file manually (i.e. it goes away). See the following image:

To get informed about possible causes of this, I’ve switched to nm-connection-editor command in Terminal. Obviously, the problem continued to happen after using the command, and the output was not so informational:

(nm-connection-editor:59273): Gtk-WARNING **: 22:13:50.634: GtkGrid does not have a child property called expand
(nm-connection-editor:59273): Gtk-WARNING **: 22:13:50.634: GtkGrid does not have a child property called fill
** Message: 22:13:51.311: Cannot save connection due to error: Invalid setting VPN: cert: No key set
** Message: 22:14:15.594: Connection validates and can be saved

One thing I should mention is, that all files exist in .cert directory in my home, and needed policies have been set for it (i.e. unconfined_u:object_r:home_cert_t:s0).

This is what I tried so far, but no luck:

  1. Restoring SELinux configurations for .cert directory. (As a result, it should not be an SELinux problem.)
  2. Removing .cert and trying again.
  3. Maximizing the permissions of whole files inside .cert/nm-openvpn directory (i.e. setting them to 777).
  4. The solution here. Added a separated file in .cert directory (out of nm-openvpn) containing the key value (with or without a new line at the end of file), and used that file as key file. Nothing changed.

Thanks in advance.

1 Like

There is this open bug https://gitlab.gnome.org/GNOME/NetworkManager-openvpn/-/issues/50 on NetworkManager-openvpn.
It seems that it was patched a couple of days ago, so we only have to wait that the update will hit the Fedora repositories.

3 Likes

Good. Waiting for the patch.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.