"Problem: confilicting requests" 36 upgrade snag

Problem: conflicting requests  
  - nothing provides module(platform:f35) needed by module nodejs:12:3520220113124632:f27b74a8.x86_64

I have no idea what this means. So far upgaded system seems fine. But I get this anytime I do anythong with dnf – additional updates might be problematic.

How did you upgrade to 36?

1 Like

Hi @depling, I had a similar issue with an old Ruby package after running some post-upgrade clean-ups.

I ended-up entering: sudo dnf module disable ruby and that did the trick for me.
I guess that sudo dnf module disable nodejs would work for you.
Important: Please note that I’m not sure if that’s the best way to troubleshoot our issue.

You are correct sir! That command seems to have fixed the trouble. After, I ran dnf upgrade which completed without the “conflicting requests” message. Thanks for your help.

1 Like