Problem with installed package nodejs

,

Hello,

I have an issue while i try to update my system, it says that can’t update nodejs because nothing provides /usr/bin/pwsh needed by nodejs. I don’t know what to do to solve this specific problem, should i wait for the next update to get my problem solved?

sudo dnf update                                                                           130 ↵
Last metadata expiration check: 3:35:16 ago on Wed 23 Feb 2022 12:52:12 AM CST.
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package nodejs-1:14.17.2-2.module_f35+12348+fe4be0bd.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.module_f35+13766+ad18d3e5.x86_64
 Problem 2: package npm-1:6.14.16-1.14.19.0.2.module_f35+13766+ad18d3e5.x86_64 requires nodejs = 1:14.19.0-2.module_f35+13766+ad18d3e5, but none of the providers can be installed
  - cannot install the best update candidate for package npm-1:6.14.13-1.14.17.2.2.module_f35+12348+fe4be0bd.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.module_f35+13766+ad18d3e5.x86_64
 Problem 3: package nodejs-full-i18n-1:14.19.0-2.module_f35+13766+ad18d3e5.x86_64 requires nodejs(x86-64) = 1:14.19.0-2.module_f35+13766+ad18d3e5, but none of the providers can be installed
  - cannot install the best update candidate for package nodejs-full-i18n-1:14.17.2-2.module_f35+12348+fe4be0bd.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.module_f35+13766+ad18d3e5.x86_64
 Problem 4: package nodejs-devel-1:14.19.0-2.module_f35+13766+ad18d3e5.x86_64 requires nodejs(x86-64) = 1:14.19.0-2.module_f35+13766+ad18d3e5, but none of the providers can be installed
  - cannot install the best update candidate for package nodejs-devel-1:14.17.2-2.module_f35+12348+fe4be0bd.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.module_f35+13766+ad18d3e5.x86_64
 Problem 5: problem with installed package nodejs-1:14.17.2-2.module_f35+12348+fe4be0bd.x86_64
  - package nodejs-docs-1:14.19.0-2.module_f35+13766+ad18d3e5.noarch conflicts with nodejs < 1:14.19.0-2.module_f35+13766+ad18d3e5 provided by nodejs-1:14.17.2-2.module_f35+12348+fe4be0bd.x86_64
  - cannot install the best update candidate for package nodejs-docs-1:14.17.2-2.module_f35+12348+fe4be0bd.noarch
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.module_f35+13766+ad18d3e5.x86_64
 Problem 6: problem with installed package npm-1:6.14.13-1.14.17.2.2.module_f35+12348+fe4be0bd.x86_64
  - package npm-1:6.14.13-1.14.17.2.2.module_f35+12348+fe4be0bd.x86_64 requires nodejs = 1:14.17.2-2.module_f35+12348+fe4be0bd, but none of the providers can be installed
  - package nodejs-1:14.17.2-2.module_f35+12348+fe4be0bd.x86_64 requires nodejs-libs(x86-64) = 1:14.17.2-2.module_f35+12348+fe4be0bd, but none of the providers can be installed
  - cannot install both nodejs-libs-1:14.19.0-2.module_f35+13766+ad18d3e5.x86_64 and nodejs-libs-1:14.17.2-2.module_f35+12348+fe4be0bd.x86_64
  - package npm-1:6.14.16-1.14.19.0.2.module_f35+13766+ad18d3e5.x86_64 requires nodejs = 1:14.19.0-2.module_f35+13766+ad18d3e5, but none of the providers can be installed
  - cannot install the best update candidate for package nodejs-libs-1:14.17.2-2.module_f35+12348+fe4be0bd.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.module_f35+13766+ad18d3e5.x86_64
====================================================================================================
 Package           Arch    Version                                           Repository        Size
====================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 nodejs-docs       noarch  1:14.19.0-2.module_f35+13766+ad18d3e5             updates-modular  6.2 M
 nodejs-libs       x86_64  1:14.19.0-2.module_f35+13766+ad18d3e5             updates-modular   13 M
Skipping packages with broken dependencies:
 nodejs            x86_64  1:14.19.0-2.module_f35+13766+ad18d3e5             updates-modular  199 k
 nodejs-devel      x86_64  1:14.19.0-2.module_f35+13766+ad18d3e5             updates-modular  156 k
 nodejs-full-i18n  x86_64  1:14.19.0-2.module_f35+13766+ad18d3e5             updates-modular  8.1 M
 npm               x86_64  1:6.14.16-1.14.19.0.2.module_f35+13766+ad18d3e5   updates-modular  3.3 M

Transaction Summary
====================================================================================================
Skip  6 Packages

Nothing to do.
Complete!

Note: I have already entered these commands but nothing solved my problem:

sudo dnf distro-sync

sudo dnf clean all
sudo dnf check
sudo dnf check-update
sudo dnf update
1 Like

Sudo dnf reinstall packages*
Which are showing you issues.

Probably want to file a bug for the module for stream 14 for the issue.

You can remove and disable the module and install from the repos or use a different module:stream if that works.

Sadly, the problem is still appearing despite i reinstalled those packages

Thank you, i will definitely report the bug and i will wait until they release the fix for the bug. I didn’t know what to do and i was not sure if it really was a bug

I am not sure that is a bug.

Your update may simply be trying to pull in update packages from a mirror that is not fully synced with the fedora repo so it cannot do a full update and is telling you that.

In my experience I usually wait a day or 2 and the update completes normally. Usually fedora releases most of the updates on Tuesday and it does take some time for all the mirrors to sync with the source repo. Your update was at about 1 AM on Wed so it probably was caused by the update process for the mirrors.

Try again tonight or tomorrow and the issue will likely be gone.

1 Like

This is a bug; there is no /usr/bin/pwsh in Fedora.

The same problem occurred on Fedora 34 (which is nodejs 14 by default):
https://bugzilla.redhat.com/show_bug.cgi?id=2053637

Since you are on Fedora 35 with the nodejs:14 stream, you should report that that is also broken either in that report or a new one. I do not see any updates in testing for nodejs:14.

3 Likes

Thank you so much, i have already done the report:

https://bugzilla.redhat.com/show_bug.cgi?id=2057477

1 Like

It looks like it was somehow compiled with a powershell dependency. While this shouldn’t be part of a Fedora package dependency, it is possible to install Powershell on Fedora, as a workaround:

2 Likes

The fix for this has been pushed to the updates-testing-modular repository, as described in the bug report. You can get it right now like this:

# assuming "nodejs:14" already enabled
sudo dnf install nodejs --enablerepo=updates-testing-modular --best

Command reference: QA:Updates Testing - Fedora Project Wiki

Hopefully it’ll hit the stable repository soon.

1 Like