Problem with updates of fedora 31

why do i get the message unable to download updates:
error running transaction:
libqb.so.0()(64bit) is needed by corosynclib-3.0.3-1fc31.x86_64.

i have a fedora 31 and no idea how to solve this issue at the moment

Hi;

Can you post the whole information provided when you do run sudo dnf upgrade? Did you try update with someone of the options --best / --skip-broken / --allowerasing

Regards

@xtym that is the whole information i get

Try update with this command:

sudo dnf --best --allowerasing --skip-broken upgrade

If the problem persist you can try remove the packages than are causing the problem/s before you update and after install they again if you need them, take a register/log of all than you do delete (if it is the case) because it will be more easy than look into dnf.log what can be complicate sometimes.

Regards.

thanks, for the tip that works