Problema con flatpak

Hola compañeros de la comunidad necesito de su ayuda con flatpak ya que me arroja el sieguiente error;
Note that the directories

‘/var/lib/flatpak/exports/share’
‘/home/dowar/.local/share/flatpak/exports/share’

are not in the search path set by the XDG_DATA_DIRS environment variable, so
applications installed by Flatpak may not appear on your desktop until the
session is restarted.

Estoy utilizando fedora 31 con plasma.
De antemano gracias por su ayuda…

Hola @dowar …! ¡Bienvenido a la comunidad! Tómese unos minutos cuando tenga tiempo para repasar las publicaciones introductorias en #start-here. Contienen mucha información útil.

Primero tenemos que saber que shell estas utilizando:

proveenos de la siguiente información:

echo "$SHELL"
ps -p $
cat /etc/shells
grep "^$USER" /etc/passwd

He visto varios error de flatpak ejecutando en una shell sin soporte:

Ejemplo:

https://www.reddit.com/r/openSUSE/comments/cyq503anyone_having_problems_with_xdg_flatpak_and_snap/

es de otra distro pero con el mismo problema…

Saludos.,

La shell que utilizo es fish
echo “$SHELL”

ps -p 
    
cat /etc/shells

grep "^$USER" /etc/passwd

/bin/bash
error: list of process IDs must follow -p

Usage:
ps [options]

Try ‘ps --help <simple|list|output|threads|misc|all>’
or ‘ps --help <s|l|o|t|m|a>’
for additional help text.

For more details see ps(1).
/bin/sh
/bin/bash
/usr/bin/sh
/usr/bin/bash
/usr/bin/tmux
/bin/tmux
/usr/bin/fish
/bin/fish
dowar:x:1000:1000:dowar:/home/dowar:/usr/bin/fish

Cambiate de shell y veras como todo funciona, es un problema de compatibilidad de tu shell (fish) y flatpak, deberias contactar con el equipo de desarrollo de fish o incluso con flatpak para que den soporte en ese entorno y notificar el problema… ya que es algo que no podemos manejar desde aqui…

para cambiar de shell:

chsh -s /bin/bash

lo siento no tienes muchas alternativas aqui

NOTA

puedes ver como trabaja flatpak en estos link:


Regards.,

1 Like

Muchas gracias la verdad es que si funciona correctamente con bash, fuiste muy amable, nuevamente gracias.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.