Problems upgrading 33 to 34 workstation

I’ve filtered out some of the problems I have with the upgrade:

  • package xorg-x11-drv-nvidia-3:465.24.02-4.fc34.x86_64 is filtered out by modular filtering
    Problem 2: rdma-core-34.0-1.fc33.i686 has inferior architecture

  • rdma-core-34.0-1.fc33.x86_64 does not belong to a distupgrade repository

  • problem with installed package rdma-core-34.0-1.fc33.i686
    Problem 3: package xorg-x11-drv-nvidia-cuda-3:465.24.02-4.fc33.x86_64 requires nvidia-persistenced(x86-64) = 3:465.24.02, but none of the providers can be installed

  • nvidia-persistenced-3:465.24.02-1.fc33.x86_64 does not belong to a distupgrade repository

  • problem with installed package xorg-x11-drv-nvidia-cuda-3:465.24.02-4.fc33.x86_64

  • package nvidia-persistenced-3:465.24.02-1.fc34.x86_64 is filtered out by modular filtering
    Problem 4: package xorg-x11-drv-nvidia-3:465.24.02-4.fc33.x86_64 requires nvidia-settings(x86-64) = 3:465.24.02, but none of the providers can be installed

  • package kmod-nvidia-5.11.15-200.fc33.x86_64-3:465.24.02-1.fc33.x86_64 requires nvidia-kmod-common >= 3:465.24.02, but none of the providers can be installed

  • nvidia-settings-3:465.24.02-1.fc33.x86_64 does not belong to a distupgrade repository

  • problem with installed package kmod-nvidia-5.11.15-200.fc33.x86_64-3:465.24.02-1.fc33.x86_64

  • package nvidia-settings-3:465.24.02-1.fc34.x86_64 is filtered out by modular filtering

  • package xorg-x11-drv-nvidia-3:465.24.02-4.fc34.x86_64 is filtered out by modular filtering
    Problem 5: package xorg-x11-drv-nvidia-3:465.24.02-4.fc33.x86_64 requires xorg-x11-drv-nvidia-libs(x86-64) = 3:465.24.02-4.fc33, but none of the providers can be installed

  • package kmod-nvidia-5.11.16-200.fc33.x86_64-3:465.24.02-1.fc33.x86_64 requires nvidia-kmod-common >= 3:465.24.02, but none of the providers can be installed

  • xorg-x11-drv-nvidia-libs-3:465.24.02-4.fc33.x86_64 does not belong to a distupgrade repository

  • problem with installed package kmod-nvidia-5.11.16-200.fc33.x86_64-3:465.24.02-1.fc33.x86_64

  • package xorg-x11-drv-nvidia-3:465.24.02-4.fc34.x86_64 is filtered out by modular filtering
    Problem 6: package signon-glib-2.1-13.fc34.x86_64 requires signond >= 8.60, but none of the providers can be installed

  • package gsignond-1.2.0-9.fc34.x86_64 conflicts with signon provided by signon-8.60-8.fc34.i686

  • package signon-8.60-8.fc34.i686 conflicts with gsignond provided by gsignond-1.2.0-9.fc34.x86_64

  • package gsignond-1.2.0-9.fc34.x86_64 conflicts with signon provided by signon-8.60-8.fc34.x86_64

  • package signon-8.60-8.fc34.x86_64 conflicts with gsignond provided by gsignond-1.2.0-9.fc34.x86_64

  • problem with installed package signon-glib-2.1-11.fc33.x86_64

  • problem with installed package gsignond-1.2.0-8.fc33.x86_64

  • signon-glib-2.1-11.fc33.x86_64 does not belong to a distupgrade repository

  • gsignond-1.2.0-8.fc33.x86_64 does not belong to a distupgrade repository
    Problem 7: conflicting requests

  • package pipewire-pulseaudio-0.3.26-3.fc34.x86_64 conflicts with pulseaudio provided by pulseaudio-14.2-3.fc34.x86_64

  • package pipewire-pulseaudio-0.3.26-3.fc34.x86_64 conflicts with pulseaudio-daemon provided by pulseaudio-14.2-3.fc34.x86_64

  • package pulseaudio-14.2-3.fc34.x86_64 conflicts with pulseaudio-daemon provided by pipewire-pulseaudio-0.3.26-3.fc34.x86_64

  • package pipewire-pulseaudio-0.3.25-1.fc34.x86_64 conflicts with pulseaudio provided by pulseaudio-14.2-3.fc34.x86_64

  • package pipewire-pulseaudio-0.3.25-1.fc34.x86_64 conflicts with pulseaudio-daemon provided by pulseaudio-14.2-3.fc34.x86_64

  • package pulseaudio-14.2-3.fc34.x86_64 conflicts with pulseaudio-daemon provided by pipewire-pulseaudio-0.3.25-1.fc34.x86_64

  • package xpra-4.1.1-1.fc34.x86_64 requires pulseaudio, but none of the providers can be installed

  • problem with installed package xpra-4.1.1-1.fc33.x86_64

  • xpra-4.1.1-1.fc33.x86_64 does not belong to a distupgrade repository

  • pulseaudio-14.0-2.fc33.x86_64 does not belong to a distupgrade repository
    Problem 8: problem with installed package xorg-x11-drv-nvidia-libs-3:465.24.02-4.fc33.i686

  • package nvidia-driver-libs-3:465.19.01-2.fc33.x86_64 obsoletes xorg-x11-drv-nvidia-libs provided by xorg-x11-drv-nvidia-libs-3:465.24.02-4.fc33.i686

  • package nvidia-driver-libs-3:465.19.01-2.fc33.x86_64 obsoletes xorg-x11-drv-nvidia-libs provided by xorg-x11-drv-nvidia-libs-3:465.24.02-4.fc34.i686

  • package cuda-drivers-465.19.01-1.x86_64 requires nvidia-driver-libs >= 3:465.19.01, but none of the providers can be installed

  • problem with installed package cuda-runtime-10-2-10.2.89-1.x86_64

  • package cuda-drivers-440.33.01-1.x86_64 is filtered out by modular filtering

  • package xorg-x11-drv-nvidia-cuda-3:465.24.02-4.fc34.x86_64 is filtered out by modular filtering

that’s more worrying:

  • package pipewire-pulseaudio-0.3.26-3.fc34.x86_64 conflicts with pulseaudio provided by pulseaudio-14.2-3.fc34.x86_64
  • package pipewire-pulseaudio-0.3.26-3.fc34.x86_64 conflicts with pulseaudio-daemon provided by pulseaudio-14.2-3.fc34.x86_64
  • package pulseaudio-14.2-3.fc34.x86_64 conflicts with pulseaudio-daemon provided by pipewire-pulseaudio-0.3.26-3.fc34.x86_64
  • package pipewire-pulseaudio-0.3.25-1.fc34.x86_64 conflicts with pulseaudio provided by pulseaudio-14.2-3.fc34.x86_64
  • package pipewire-pulseaudio-0.3.25-1.fc34.x86_64 conflicts with pulseaudio-daemon provided by pulseaudio-14.2-3.fc34.x86_64
  • package pulseaudio-14.2-3.fc34.x86_64 conflicts with pulseaudio-daemon provided by pipewire-pulseaudio-0.3.25-1.fc34.x86_64
  • package xpra-4.1.1-1.fc34.x86_64 requires pulseaudio, but none of the providers can be installed
  • problem with installed package xpra-4.1.1-1.fc33.x86_64
  • xpra-4.1.1-1.fc33.x86_64 does not belong to a distupgrade repository
  • pulseaudio-14.0-2.fc33.x86_64 does not belong to a distupgrade repository

any ideas about the problem with pipewire and pulseaudio? Since I thought that fedora 34 was only relying on pipewire, so why those errors?

Thanks in advance

You can proceed with system upgrade by removing the problematic packages:

sudo rpm --nodeps -e pulseaudio

didn’t work.

$ sudo rpm --nodeps -e pulseaudio
Removed /etc/systemd/user/sockets.target.wants/pulseaudio.socket.

still got:

Error:

Problem 1: rdma-core-34.0-1.fc33.i686 has inferior architecture

  • rdma-core-34.0-1.fc33.x86_64 does not belong to a distupgrade repository
  • problem with installed package rdma-core-34.0-1.fc33.i686
    Problem 2: package signon-glib-2.1-13.fc34.x86_64 requires signond >= 8.60, but none of the providers can be installed
  • package gsignond-1.2.0-9.fc34.x86_64 conflicts with signon provided by signon-8.60-8.fc34.i686
  • package signon-8.60-8.fc34.i686 conflicts with gsignond provided by gsignond-1.2.0-9.fc34.x86_64
  • package gsignond-1.2.0-9.fc34.x86_64 conflicts with signon provided by signon-8.60-8.fc34.x86_64
  • package signon-8.60-8.fc34.x86_64 conflicts with gsignond provided by gsignond-1.2.0-9.fc34.x86_64
  • problem with installed package signon-glib-2.1-11.fc33.x86_64
  • problem with installed package gsignond-1.2.0-8.fc33.x86_64
  • signon-glib-2.1-11.fc33.x86_64 does not belong to a distupgrade repository
  • gsignond-1.2.0-8.fc33.x86_64 does not belong to a distupgrade repository
    Problem 3: conflicting requests
  • package pipewire-pulseaudio-0.3.26-3.fc34.x86_64 conflicts with pulseaudio provided by pulseaudio-14.2-3.fc34.x86_64
  • package pipewire-pulseaudio-0.3.26-3.fc34.x86_64 conflicts with pulseaudio-daemon provided by pulseaudio-14.2-3.fc34.x86_64
  • package pulseaudio-14.2-3.fc34.x86_64 conflicts with pulseaudio-daemon provided by pipewire-pulseaudio-0.3.26-3.fc34.x86_64
  • package pipewire-pulseaudio-0.3.25-1.fc34.x86_64 conflicts with pulseaudio provided by pulseaudio-14.2-3.fc34.x86_64
  • package pipewire-pulseaudio-0.3.25-1.fc34.x86_64 conflicts with pulseaudio-daemon provided by pulseaudio-14.2-3.fc34.x86_64
  • package pulseaudio-14.2-3.fc34.x86_64 conflicts with pulseaudio-daemon provided by pipewire-pulseaudio-0.3.25-1.fc34.x86_64
  • package xpra-4.1.1-1.fc34.x86_64 requires pulseaudio, but none of the providers can be installed
  • problem with installed package xpra-4.1.1-1.fc33.x86_64
  • xpra-4.1.1-1.fc33.x86_64 does not belong to a distupgrade repository
    (try to add ‘–allowerasing’ to command line to replace conflicting packages or ‘–skip-broken’ to skip uninstallable packages)

It’s a combination of problems.
Igot one part:

One part was because of steam which is now removed, it needs still i686 libraries and equivalent packages:
https://libredd.it/r/Fedora/comments/mzy05u/f34_upgrade_dnf_pipewire_error/
https://libredd.it/r/Fedora/comments/mz0ytg/upgrade_to_fedora_34_problems/
https://libredd.it/r/Fedora/comments/mynp7s/dnf_up_error_for_pipewire/gvw7dxm?utm_source=share&utm_medium=web2x&context=3

Then I removed every i686 installation about pipewire and pulseaudio which removed a bunch of other stuffs too.
Then I removed bunch of nvidia drivers stuffs and cuda through --allowerasing --best which reinstalled nvidia-dkms etc which
=> no more nvidia error message about packages.

but still there are pulseaudio problem+rdma + other stuffs that I don’t know the origin.

and if I still re-do --allowerasing --best then I got:

Error:
Problem: cannot install the best update candidate for package iptables-1.8.5-6.fc33.x86_64

  • problem with installed package iptables-1.8.5-6.fc33.x86_64
  • package iptables-1.8.7-3.fc34.x86_64 requires iptables-libs(x86-64) = 1.8.7-3.fc34, but none of the providers can be installed
  • cannot install the best update candidate for package iptables-libs-1.8.5-6.fc33.x86_64
  • cannot install both iptables-libs-1.8.7-3.fc34.x86_64 and iptables-libs-1.8.7-6.fc34.x86_64
  • iptables-1.8.5-6.fc33.x86_64 does not belong to a distupgrade repository

Plus of course each time I got:

No match for group package “xorg-x11-drv-armsoc”
No match for group package “vt323-fonts”
No match for group package “google-croscore-symbolneu-fonts”
No match for group package “aldusleaf-crimson-text-fonts”
No match for group package “trabajo-fonts”
No match for group package “fedora-user-agent-chrome”
No match for group package “ht-alegreya-smallcaps-fonts”
No match for group package “senamirmir-washra-wookianos-fonts”
No match for group package “sarai-fonts”
No match for group package “wallpoet-fonts”
No match for group package “google-crosextra-carlito-fonts”
No match for group package “oflb-brett-fonts”
No match for group package “cyreal-wireone-fonts”
No match for group package “kranky-fonts”
No match for group package “atomic”
No match for group package “moyogo-molengo-fonts”
No match for group package “cockpit-docker”
No match for group package “senamirmir-washra-zelan-fonts”
No match for group package “oflb-sportrop-fonts”
No match for group package “powerpc-utils”
No match for group package “min12xxw”
No match for group package “google-noto-sans-balinese-fonts”
No match for group package “docker”
No match for group package “smc-kalyani-fonts”
No match for group package “google-crosextra-caladea-fonts”
No match for group package “ecolier-court-lignes-fonts”
No match for group package “tuladha-jejeg-fonts”
No match for group package “google-croscore-arimo-fonts”
No match for group package “khmeros-handwritten-fonts”
No match for group package “stix-math-fonts”
No match for group package “senamirmir-washra-hiwua-fonts”
No match for group package “khmeros-bokor-fonts”
No match for group package “senamirmir-washra-jiret-fonts”
No match for group package “astloch-fonts”
No match for group package “impallari-lobster-fonts”
No match for group package “cf-sorts-mill-goudy-fonts”
No match for group package “senamirmir-washra-yebse-fonts”
No match for group package “khmeros-siemreap-fonts”
No match for group package “oflb-roadstencil-fonts”
No match for group package “apanov-edrip-fonts”
No match for group package “pagul-fonts”
No match for group package “khmeros-metal-chrieng-fonts”
No match for group package “xorg-x11-drv-geode”
No match for group package “tangerine-fonts”
No match for group package “tharlon-fonts”
No match for group package “senamirmir-washra-tint-fonts”
No match for group package “paratype-pt-sans-fonts”
No match for group package “google-noto-sans-ui-fonts”
No match for group package “tabish-eeyek-fonts”
No match for group package “monofett-fonts”
No match for group package “almas-mongolian-title-fonts”
No match for group package “isight-firmware-tools”
No match for group package “shadowsintolight-fonts”
No match for group package “tlomt-orbitron-fonts”
No match for group package “carterone-fonts”
No match for group package “google-croscore-cousine-fonts”
No match for group package “smc-raghumalayalam-fonts”
No match for group package “senamirmir-washra-yigezu-bisrat-goffer-fonts”
No match for group package “oflb-icelandic-fonts”
No match for group package “khmeros-muol-fonts”
No match for group package “typemade-josefinsansstd-light-fonts”
No match for group package “paratype-pt-sans-caption-fonts”
No match for group package “xorg-x11-drv-omap”
No match for group package “google-croscore-tinos-fonts”
No match for group package “labelleaurore-fonts”
No match for group package “reeniebeanie-fonts”
No match for group package “inkboy-fonts”
No match for group package “bcm283x-firmware”
No match for group package “khmeros-battambang-fonts”
No match for group package “phetsarath-fonts”
No match for group package “mph-2b-damase-fonts”
No match for group package “senamirmir-washra-yigezu-bisrat-gothic-fonts”
No match for group package “senamirmir-washra-fantuwua-fonts”
No match for group package “lsvpd”
No match for group package “totem-nautilus”
No match for group package “specialelite-fonts”
No match for group package “google-droid-kufi-fonts”

but that’s normal I guess

and I can’t shake around my head that there is no upgrade compatibilities about iptables version between 33 and 34 … where is that coming from?

Remove all the problematic packages.
Some of those will be replaced automatically by other packages.
And you can reinstall the remaining after the upgrade if necessary.

okey had to remove rdma, xpra, gsignond (which i think was part of the system?)
pipewire problem was I guess part of the xpra dependencies. upgrade to 34 is on the way now.

1 Like

You can remove cached packages by executing ‘dnf clean packages’.
Error: Transaction test error:
file /usr/lib64/libcuda.so conflicts between attempted installs of xorg-x11-drv-nvidia-cuda-libs-3:465.24.02-4.fc34.x86_64 and nvidia-driver-cuda-libs-3:465.19.01-2.fc33.x86_64
file /usr/lib64/libcuda.so.1 conflicts between attempted installs of xorg-x11-drv-nvidia-cuda-libs-3:465.24.02-4.fc34.x86_64 and nvidia-driver-cuda-libs-3:465.19.01-2.fc33.x86_64
file /usr/lib64/libnvcuvid.so.1 conflicts between attempted installs of xorg-x11-drv-nvidia-cuda-libs-3:465.24.02-4.fc34.x86_64 and nvidia-driver-cuda-libs-3:465.19.01-2.fc33.x86_64
file /usr/lib64/libnvidia-encode.so.1 conflicts between attempted installs of xorg-x11-drv-nvidia-cuda-libs-3:465.24.02-4.fc34.x86_64 and nvidia-driver-cuda-libs-3:465.19.01-2.fc33.x86_64
file /usr/lib64/libnvidia-opencl.so.1 conflicts between attempted installs of xorg-x11-drv-nvidia-cuda-libs-3:465.24.02-4.fc34.x86_64 and nvidia-driver-cuda-libs-3:465.19.01-2.fc33.x86_64
file /usr/lib64/libnvidia-opticalflow.so.1 conflicts between attempted installs of xorg-x11-drv-nvidia-cuda-libs-3:465.24.02-4.fc34.x86_64 and nvidia-driver-cuda-libs-3:465.19.01-2.fc33.x86_64
file /usr/lib64/libnvidia-ptxjitcompiler.so.1 conflicts between attempted installs of xorg-x11-drv-nvidia-cuda-libs-3:465.24.02-4.fc34.x86_64 and nvidia-driver-cuda-libs-3:465.19.01-2.fc33.x86_64

Update:
deleted the cuda occurence in nvidia installation manually. Now I can apaprently successfully reboot to upgrade.

1 Like

this is a bit a pain in the ass as an upgrade ^^
of course I understand that every soft can’t be in the upgrade process. But even for the nvidia driver now I got problems since I can’t seem to find any good 465 version for

xorg-x11-drv-nvidia

> Ignoring repositories: fedora-cisco-openh264
> Last metadata expiration check: 0:00:56 ago on Fri 30 Apr 2021 12:41:56 AM CEST.
> ====================================== Name Exactly Matched: xorg-x11-drv-nvidia-libs =======================================
> xorg-x11-drv-nvidia-libs.i686 : Libraries for xorg-x11-drv-nvidia
> xorg-x11-drv-nvidia-libs.x86_64 : Libraries for xorg-x11-drv-nvidia
> [admin@fedotest ~]$ sudo rpm -qa | grep nvidia
> nvidia-kmod-common-465.19.01-3.fc33.x86_64
> kmod-nvidia-latest-dkms-465.19.01-1.fc33.x86_64
> nvidia-driver-libs-465.19.01-2.fc33.x86_64
> nvidia-driver-465.19.01-2.fc33.x86_64
> nvidia-driver-cuda-libs-465.19.01-2.fc33.x86_64
> nvidia-driver-cuda-465.19.01-2.fc33.x86_64
> nvidia-persistenced-465.19.01-1.fc33.x86_64
> xorg-x11-drv-nvidia-kmodsrc-465.24.02-4.fc34.x86_64
> [admin@fedotest ~]$ sudo dnf remove nvidia-driver-libs-3:465.19.01-2.fc33.x86_64 
> Dependencies resolved.
> =============================================================================================================================
>  Package                           Architecture     Version                        Repository                           Size
> =============================================================================================================================
> Removing:
>  nvidia-driver-libs                x86_64           3:465.19.01-2.fc33             @cuda-fedora33-11-3-local           317 M
> Removing dependent packages:
>  nvidia-driver                     x86_64           3:465.19.01-2.fc33             @cuda-fedora33-11-3-local            60 M
> Removing unused dependencies:
>  dkms                              noarch           2.8.4-2.fc34                   @fedora                             224 k
>  egl-wayland                       x86_64           1.1.6-2.fc34                   @fedora                              58 k
>  kmod-nvidia-latest-dkms           x86_64           3:465.19.01-1.fc33             @cuda-fedora33-11-3-local            47 M
>  nvidia-kmod-common                x86_64           3:465.19.01-3.fc33             @cuda-fedora33-11-3-local           2.7 k
> 
> Transaction Summary
> =============================================================================================================================
> Remove  6 Packages
> 
> Freed space: 423 M
> Is this ok [y/N]: 

this make no sense. It should have been upgraded during the upgrade since there is an actual package to replace it :
https://fedora.pkgs.org/34/rpmfusion-nonfree-x86_64/xorg-x11-drv-nvidia-libs-465.24.02-4.fc34.x86_64.rpm.html

so I guess this modular thing is linked to that ?

This is kinda of upsetting. I had to manually download from rpmfusion through wget and the links from pkg every nvidia base driver more or less.

And all of that so that I still get stucked while trying the toxicoder script:

Errors during downloading metadata for repository ‘fedora-cisco-openh264’:

  • Status code: 404 for https://codecs.fedoraproject.org/openh264/34/x86_64/repodata/repomd.xml (IP: 152.19.134.198)
    Error: Failed to download metadata for repo ‘fedora-cisco-openh264’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
    Ignoring repositories: fedora-cisco-openh264
    Last metadata expiration check: 0:09:57 ago on Fri 30 Apr 2021 01:19:17 AM CEST.
    Error:
    Problem 1: package nvidia-kmod-common-3:465.19.01-3.fc33.x86_64 requires nvidia-kmod = 3:465.19.01, but none of the providers can be installed
  • conflicting requests
  • package kmod-nvidia-latest-dkms-3:465.19.01-1.fc33.x86_64 is filtered out by modular filtering
    Problem 2: package nvidia-driver-3:465.19.01-2.fc33.x86_64 obsoletes xorg-x11-drv-nvidia provided by xorg-x11-drv-nvidia-3:465.24.02-4.fc34.x86_64
  • package kmod-nvidia-5.11.16-300.fc34.x86_64-3:465.24.02-1.fc34.x86_64 requires nvidia-kmod-common >= 3:465.24.02, but none of the providers can be installed
  • conflicting requests
  • problem with installed package kmod-nvidia-5.11.16-300.fc34.x86_64-3:465.24.02-1.fc34.x86_64
  • package xorg-x11-drv-nvidia-3:465.24.02-4.fc34.x86_64 is filtered out by modular filtering
    Problem 3: package nvidia-driver-3:465.19.01-2.fc33.x86_64 requires nvidia-kmod-common = 3:465.19.01, but none of the providers can be installed
  • package cuda-drivers-465.19.01-1.x86_64 requires nvidia-driver >= 3:465.19.01, but none of the providers can be installed
  • package nvidia-kmod-common-3:465.19.01-3.fc33.x86_64 requires nvidia-kmod = 3:465.19.01, but none of the providers can be installed
  • conflicting requests
  • package kmod-nvidia-latest-dkms-3:465.19.01-1.fc33.x86_64 is filtered out by modular filtering
  • package xorg-x11-drv-nvidia-cuda-3:465.24.02-4.fc34.x86_64 is filtered out by modular filtering
    Problem 4: package nvidia-driver-3:465.19.01-2.fc33.x86_64 requires nvidia-kmod-common = 3:465.19.01, but none of the providers can be installed
  • package nvidia-settings-3:465.19.01-1.fc33.x86_64 requires nvidia-driver(x86-64) = 3:465.19.01, but none of the providers can be installed
  • package nvidia-kmod-common-3:465.19.01-3.fc33.x86_64 requires nvidia-kmod = 3:465.19.01, but none of the providers can be installed
  • conflicting requests
  • package kmod-nvidia-latest-dkms-3:465.19.01-1.fc33.x86_64 is filtered out by modular filtering
    Problem 5: problem with installed package akmod-nvidia-3:465.24.02-1.fc34.x86_64
  • package akmod-nvidia-3:465.24.02-1.fc34.x86_64 requires nvidia-kmod-common >= 3:465.24.02, but none of the providers can be installed
  • package xorg-x11-drv-nvidia-3:465.24.02-4.fc34.x86_64 requires libnvidia-glcore.so.465.24.02()(64bit), but none of the providers can be installed
  • package xorg-x11-drv-nvidia-3:465.24.02-4.fc34.x86_64 requires libnvidia-tls.so.465.24.02()(64bit), but none of the providers can be installed
  • package xorg-x11-drv-nvidia-3:465.24.02-4.fc34.x86_64 requires xorg-x11-drv-nvidia-libs(x86-64) = 3:465.24.02-4.fc34, but none of the providers can be installed
  • package nvidia-driver-libs-3:465.19.01-2.fc33.x86_64 obsoletes xorg-x11-drv-nvidia-libs provided by xorg-x11-drv-nvidia-libs-3:465.24.02-4.fc34.x86_64
  • conflicting requests
  • package xorg-x11-drv-nvidia-3:465.24.02-4.fc34.x86_64 is filtered out by modular filtering
    (try to add ‘–skip-broken’ to skip uninstallable packages)

and still begin stucked with fc33 version mentionned and I can’t find a single file in yum repo about fc33. So how can I delete this filtering and keeps giving me fc33 results where I want to try just to install the nvidia driver for fc34?

So thanks actually to webarchive for the links in pkg.org and to this post, I finally manage to install every single packages manually Rpm - Nvidia driver on Fedora 34, seems to have issues - #6 by vk2bea.

Can someone explain to me where is this modular filtering which is apparently the cause to not being able to have the full list of the packages in the rpmfusion repo?

Thanks in advance

I totally understand your frustrations, but since this is a public forum open to everyone, please refrain from such language that others may find offensive.

I’ve edited your post.

1 Like

I think it’s best to open a new topic about the modularity question, otherwise it’s buried here in all the other upgrade issues you’ve had.

I note that you seem to have hit a few of the common bugs with upgrading:

https://fedoraproject.org/wiki/Common_F34_bugs#Upgrade_issues

Dnf error on fedora 34 with 'fedora-cisco-openh264': wrong metadata link - #2 by vgaetera

Modularity — dnf latest documentation

1 Like

3 posts were split to a new topic: Upgrading to F34: ipatbles issues

Thanks for that,
it brings a little more clarity but not much since it doesn’t seem to assist the nvidia situation very well.
For example I have since the upgrade problems with this modularity filtering right?
Well it continues to this day since

Error:
Problem 1: problem with installed package akmod-nvidia-3:465.24.02-1.fc34.x86_64

  • cannot install the best update candidate for package akmod-nvidia-3:465.24.02-1.fc34.x86_64
  • package akmod-nvidia-3:465.27-1.fc34.x86_64 requires nvidia-kmod-common >= 3:465.27, but none of the providers can be installed
  • package xorg-x11-drv-nvidia-3:465.27-1.fc34.x86_64 is filtered out by modular filtering
    Problem 2: problem with installed package kmod-nvidia-3:465.24.02-1.fc34.x86_64
  • cannot install the best update candidate for package kmod-nvidia-3:465.24.02-1.fc34.x86_64
  • package kmod-nvidia-3:465.27-1.fc34.x86_64 requires akmod-nvidia = 3:465.27-1.fc34, but none of the providers can be installed
  • package akmod-nvidia-3:465.27-1.fc34.x86_64 requires nvidia-kmod-common >= 3:465.27, but none of the providers can be installed
  • package xorg-x11-drv-nvidia-3:465.27-1.fc34.x86_64 is filtered out by modular filtering
    (try to add ‘–skip-broken’ to skip uninstallable packages)

but I’m still able to download it from pkg.org and install manually. So then there might be a problem with one of the package that is not declared at all as being part of the nvidia module…

I installed xpra a few Fedora releases ago. It came from its own repository that was sometimes out of sync with Fedora’s repository. If you haven’t done it already, try removing xpra and any other packages that are not from Fedora. After the upgrade, you can re-install them.

1 Like

As I said earlier xpra is no a problem anymore and indeed yeah there was no transition protocol for the upgrade so I had to remove and reinstall it again

1 Like

Than ks by the way for that.
So what should I do about the part of modular filtering? and so nvidia drivers? Should I create another thread then ?