Problems when upgrading Fedora 30 to 31

Unable to upgrade to fedora 32:
Package rpmfusion-free-obsolete-packages-32-3.fc32.noarch:cannot be verified and repo rpmfusion-free-updates is GPG enabled: failed to loopkuo digest in keyring for /bar/cache/Package kit/32/metadata/rpmfusion-free-updates-32-x86_64/packages/rpmfusion-free–obsolete-packages-32-3.fc32.noarch.rpm

Software repo
Third party repo remove all

Rpm fusion for fedora 30 - no free - nvidia driver
Rpm fusion for fedora 30 - no free - steam

 ....
 Rpm fusion for fedora 30 - no free   enabled
 Rpm fusion for fedora 30 - free - updates enabled
 Rpm fusion for fedora 30 - no free enabled
  Rpm fusion for fedora 30 - no free - updates enabled

1 Like

You can import the GPG keys manually and enforce refresh of the PackageKit cache:

sudo rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-*
sudo pkcon refresh force -c -1
2 Likes

Tried - unable to upgrade to fedora 32:

Error!??

hostnamectl

What is the output?

1 Like

You need to upgrade to F31 first, then upgrade to F32:

30 to 31

1 Like

Try to remove the key ‐‐allowerasing.

1 Like

Sudo dnf systen-upgtade download – releasever=31

–skip-broken to skip uninstallation pack

Sudo dnf systen-upgtade download --releasever=31 --skip-broken

1 Like

You can remove it temporarily and reinstall later if required:

sudo dnf remove gufw

Sudo dnf remove gufw – yes

1 Like
sudo dnf module disable maven

https://unix.stackexchange.com/a/582610

1 Like

You seem to have solved this already, but in order to properly close the thread, it should be noted that the last command must be run with sudo.

right!!

fedora 31 to 32

sudo dnf system-upgrade download --releasever=32

WineHQ packages 6.5 MB/s | 5.5 MB 00:00
Modular dependency problems:

Problem 1: conflicting requests

  • nothing provides module(platform:f31) needed by module gimp:2.10:3120191106095052:f636be4b-0.x86_64
    Problem 2: conflicting requests
  • nothing provides module(platform:f31) needed by module meson:latest:3120191009081836:dc56099c-0.x86_64
    Problem 3: conflicting requests
  • nothing provides module(platform:f31) needed by module ninja:latest:3120190304180949:f636be4b-0.x86_64
    Error:
    Problem 1: package python2-libxml2-2.9.10-4.fc31.x86_64 requires libxml2(x86-64) = 2.9.10-4.fc31, but none of the providers can be installed
  • libxml2-2.9.10-4.fc31.x86_64 does not belong to a distupgrade repository
  • problem with installed package python2-libxml2-2.9.10-4.fc31.x86_64
    Problem 2: package vim-pysmell-0.7.3-14.fc31.noarch requires python2-pysmell = 0.7.3-14.fc31, but none of the providers can be installed
  • python2-pysmell-0.7.3-14.fc31.noarch does not belong to a distupgrade repository
  • problem with installed package vim-pysmell-0.7.3-14.fc31.noarch
    (try to add ‘–skip-broken’ to skip uninstallable packages)