Problems with Dropbox on F36

I have installed Dropbox in Fedora 36 and I have noticed some problems.

The first problem is that there is no tray icon (I am using Gnome btw) when Dropbox is running.

More importantly, dropbox insists to autostart. No matter if I type dropbox autostart n or remove it through Gnome Tweaks (from the startup applications section), when I boot up dropbox runs.

What causes this behavior? I am more interested in finding a solution for the second problem since this drains my battery on my laptop.

For the system tray you have to install the extension “AppIndicator and KStatusNotifierItem Support” AppIndicator and KStatusNotifierItem Support - GNOME Shell Extensions.

Some more details here Dropbox and Gnome 42 | Lorenzo Bettini

Thanks for the info. I will check it out. As I said this is not a major problem compared to the fact that I can’t control the Dropbox’s autostart behavior.

1 Like

Thanks for the link. I had checked it before posting this question (as the accepted solution is characterized as ‘not elegant’). Also it is 5 years old, so I thought that there will be some alternative solution. I should add that this doesn’t happen on Ubuntu 20.04. Why it happens on Fedora 36?

Since Dropbox was installed by downloading the .rpm (see Dropbox installation) I removed it with (not sure if it the right way though):

sudo yum remove dropbox
sudo updatedb && locate dropbox

and then removing all the relevant files/directories.

After this, I reinstalled with the second option that the Dropbox official site provides. The installation step is:

cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -
and the dropbox daemon can be started using:

~/.dropbox-dist/dropboxd

I skipped the download of the additional python script (one can download but I only wanted a way to start and stop dropbox). So one can avoid the automatic startup of dropbox (which was present when dropbox was installed through the .rpm). To stop the dropbox daemon:

pgrep dropbox
kill -15 dropbox_pid

1 Like

Digging a little deeper regarding the RPM, It looks like it is the desktop file… running with the -i option appears to put the desktop file back into autostart.