Problems with NVIDIA graphics card on HP8710p laptop

Good evening. I am using Fedora 35 XFCE on a HP8710p laptop.

This is an older laptop, Intel Core Duo 2x2ghz, 4mb RAM, with a NVIDIA NBS Quadro 320m graphics chip and that is where my problems began.

I have used Fedora with 33, 34 and now 35 all using the XFCE desktop. Under 33 I had to fight to get NVIDIA installed but after a long time I managed to do it and all was well. Under 34 things became hellishly unstable and I had a lot of issues and eventually gave up trying to use the NVIDIA drivers.

Now I am back to 35 as a new install and I simply decided to forgo playing with NVIDIA and just use the default drivers instead and see how that went (It went well and the OS was stable) but then things changed, the OS had different ideas and after some updates suddenly my install time lengthens considerably and I get the error msg: ‘nvidia kernel module missing falling back to nouveau’ and after a few seconds of staring at that msg my system starts as normal and all seems ok.

Well, not so fast because suddenly I have experienced two system hangs forcing me to shutdown the laptop the hard way as it had become unresponsive to any keyboard input or mouse actions. And that was simply doing web browsing. Up until the error msg suddenly appeared Fedora 35 was stable and I had no issues whatsoever. But after an update now it’s becoming difficult.

Can anyone help me with this>?

From what searching I have done, I apparently need to shutdown the XServer and install the NVIDIA driver, so that is exactly what I did. I downloaded the NVIDIA driver - NVIDIA-Linux-x86_64-340.108.run

Then I went into a terminal, and shutdown the xserver (GUI) and installed the driver. Driver install seemed to go ok until it warned me about the nouveau driver and suggested that it be blacklisted, I said okey dokey and the driver install failed as it was unable to blacklist the nouveau driver.

I admit, I’m somewhat confused. I’m also stalemated by the lack of logic when it comes to driver installations on linux. Yes, the system used a default generic driver to access system graphics, etc for initial installation. Yes it’s not the proprietary driver it’s generic but surely an installation for the correct driver on this OS should contain routines to replace the generic driver with it’s own code and then point all appropriate system flags/pointers to itself, not require me to manually update grub/grub2 and then go traipsing through system files to manually change X and Y to suit the new driver.

How would that be useful or even conducive to any form of stability?

Any assistance would be gratefully appreciated. Thanks for reading.

Reganrds, John

1 Like

Hello, John.

As far as I know, NVIDIA has made some changes to their Linux support. The 340 driver should support your GPU but, if I’m not mistaken, NVIDIA has removed support for some kernel versions (can’t recall which).

That being said, there are several things to take into consideration:

  • Is the kernel version compatible with the driver version?
  • Is the driver version compatible with the kernel version?
  • Your GPU is getting pretty old (2007) which prompts the questions: what are you using your GPU for? Do you have to use the official drivers for the tasks you are executing on your machine or can you get away with using the nouveau drivers?

Try this:

  1. Check if you have secure boot enabled in the BIOS (unlikely, due to the hw’s old age).
  2. Uninstall any NVIDIA driver you have installed (any manual driver installs and/or # dnf remove -y *nvidia* to remove installs used with dnf).
  3. Use this tool to see if it helps.
  4. If everything went well, wait a couple of minutes and then shutdown -r.

If that didn’t work, try this:

  1. Enable the third-party repos (and the RPM Fusion repos, both free and non-free).
  2. Launch into tty.
  3. # dnf upgrade -y
  4. # dnf install -y gcc kernel-headers kernel-devel akmod-nvidia xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs xorg-x11-drv-nvidia-libs.i686
  5. If everything went well, wait a couple of minutes and then shutdown -r.

Please let us know how it went.

To add to what was already said.
Nvidia dropped support for the 340 drivers some time back and no longer supports any of the GPUs that it was made for. Even the 390 drivers get only minimal support if any.

The kernel updates that happen frequently also do not support those older drivers and GPUs.

You will continue to have more and more trouble keeping the nvidia drivers functioning, but you said it worked well with the nouveau driver.

I would suggest that you edit /etc/default/grub (you will need to use sudo with your favorite editor) and from the line that reads something like this

GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rd.lvm.lv=fedora/root rhgb quiet "

remove this portion (if it is there)

rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1

Save that then run

sudo grub2-mkconfig -o /etc/grub2.cfg
    if using legacy boot, or
sudo grub2-mkconfig -o /etc/grub2-efi.cfg
    if using efi

That should eliminate the attempt to load nvidia drivers at boot time.

This also presumes that you do not have the nvidia drivers installed, which can be ensured by doing

sudo dnf remove *nvidia*

if you installed them from the rpmfusion repo.

1 Like

Zeno, thank you for your detailed comments, and to be clear…

I use this HP8710p because it’s always been a very stable laptop and I like the keyboard. Primarily I use this for writing (I am a writer it’s a thing I do.) Truth be known I’d much prefer a much more mechanical keyboard (I’m old school - I really love the keyboard on my Dell M90 but that is even older than this, BUT I LOVE the keyboard)

Newer laptops all have the chicklet? style rubberised keyboards and OMG I cannot stand them. And save getting a gaming laptop just for a better keyboard I am left only with older laptops to choose from. I know it’s a weird quirk I really loved thinkpads for this very reason but they fell out of favour when they changed the one thing you know was good about them and went the way of less tactile keyboards, etc…

So that explains the old hardware.

I barely use the GPU unless I am doing any graphics work which for me is rare, so the nouveau driver WOULD be ok if this new quirk on this laptop did not suddenly make it unstable and start doing these freezing moments when everything stops responding. Has done it three times now and It’s becoming more than irritating.

Secure boot not enabled in bios and I am going to go through your steps and will update shortly. Thank you for your patience and kindness in writing this. Update to follow.

1 Like

JV I did not wish to be rude and ignore your comment. I am going to go through the steps you and Zeno outlined and I will update shortly. Thank you for reading and for your additional comments. Update to follow.

Update. I tried the suggestions made Zeno and it’s a fail. One frozen OS. Removed nvidia drivers, used the tool suggested, restarted and failed back to nouveau driver.

Sigh

Also tried the second suggestions for kernel-headers, akmod-nvidia drivers… Fail.

Heavy sigh

Going to try JV’s idea now.

Update to JV.

Removed all NVIDIA drivers, edited GRUB, saved it, rebooted and back to Fedora logo at boot and hopefully this is now back to being stable (Please let it be so)

Will update if this odd freezing issue continues. Thank you for the suggestions.

Best regards, John

I manage to install Nvidia driver 340xx from this guide here.

But if anyone want to use that guide, please read that guide carefully. Since it’s bit too long to follow.

Also pay attention to part 2.1. There notes to download script *.sh which will download patch and driver.

I’m sorry if the choice of hardware came off as criticism - that was not the intention! I was just wondering what you were using the laptop for to know if you were doing tasks that require GPU power (e.g. video editing), as that would explain why you’d need official drivers.

Sorry to hear that my suggestion didn’t work. Hopefully, JV’s suggestion will sort you out :blush:

Zeno, no problem and no need to apologise. The hardware is old but it’s sturdy LOL. Suffice to say yes it does not meet a lot of peoples current requirements, but mine are low so it does what is required (Somehow I now feel inadequate LOL)

And my stablility is back so yay on that. I May retry this again at a later date and see if I cannot make it work, I hate that Linux Mint did it so I will try this on a different hard drive later.

Thank you for all of your help. I am very grateful

1 Like

Zeno and JV.

All NVIDIA drivers have been removed and stability is back in town and all is well. Suspend and hibernate work well, I can walk away from the laptop for long periods of time and screen will be off but will come back to life when the trackpad is used or the keyboard is touched, so yay on removing and not using anything NVIDIA related.

Thank you both for your help in trying to fix this and enabling me to continue life without needing NVIDIA. I am very grateful to you both for your help.

John

1 Like

Simply use Nouveau open source drivers. NVIDIA focuses on high level AI frameworks, visit their website if you don’t use it, why bother … ?

Please do not voice personal opinions on a subject that has been closed for 8 months. Unnecessary and off topic.

I was only responding to ‘Suggested Topics’ bottom of the page while scrolling though questions.