Proper xfs_quota syntax for individual users in /home

I’m trying to set a quota for our students. Their directory is /home/students. However, in /etc/fstab we have:
/dev/mapper/fedora-home /home xfs defaults,uquota,pquota,gquota 0 0

I tried the below syntax:

xfs_quota -x -c \'limit bsoft=10g bhard=200g $USERID\' /home/
xfs_quota: cannot setup path for mount bsoft=10g: No such file or directory
xfs_quota: cannot setup path for mount bhard=200g: No such file or directory
xfs_quota: cannot setup path for mount ': No such file or directory

Here are some other options I’ve tried for individual staff members in /home/staff:

xfs_quota -x -c 'limit bsoft=120g bhard=130g ouruser' /home
xfs_quota: invalid user name: ouruser

xfs_quota -x -c 'limit bsoft=120g bhard=130g ouruser' /home/staff
xfs_quota: cannot setup path for mount /home/staff: No such device or address

Every other option I’ve tried sets the quota for all users combined. Anyone know the correct syntax?

Replace \'...\' with "...".
https://www.tldp.org/LDP/abs/html/escapingsection.html

This appears to be for individual users?

xfs_quota -x -c "limit bsoft=50g bhard=60g students" /home
xfs_quota: invalid user name: students

I’d like it so that each user within /home/students has this quota, not combined for the entire group, nor for a single user.

No, it’s the shell syntax to use variables under quotes.

See the default quotas example:

Interesting you brought that up. I posted on there a while back that I get:
xfs_quota: cannot set limits: No such process

So that is exactly what I’m trying to do. It seems Fedora or bash has a slightly different syntax or escape character required.

Here’s what ‘mount’ shows:

/dev/mapper/fedora-home on /home type xfs (rw,relatime,attr2,inode64,sunit=512,swidth=1536,prjquota)

Here’s again the same response:

xfs_quota -x -c 'limit bsoft=90g bhard=100g -d' /home
xfs_quota: cannot set limits: No such process

xfs_quota /home

xfs_quota> print
Filesystem          Pathname
/home               /dev/mapper/fedora-home (pquota)

So perhaps I have to reboot? I’ve tried to remount/home but I would think I need to see uquota from the print option?

Am I understanding this correctly then, that it only works with rtbhard=N -d ? But in Red Hat’s documentation there is this note:

Important

While real-time blocks (rtbhard/rtbsoft) are described in man xfs_quota as valid units when setting quotas, the real-time sub-volume is not enabled in this release. As such, the rtbhard and rtbsoft options are not applicable.