R openblas install error F31

Hello,

when I run dnf upgrade I get the error below. It seems that I cannot upgrade R, because it cannot find libRblas.so which was formerly provided by the package openblas-Rblas which is now superseded by the package openblas. However, it seems that R still looks for the old name?

Does anyone have the same problem and knows how to solve this?

     Problem 1: package R-core-3.6.3-2.fc31.x86_64 requires libRblas.so()(64bit), but none of the providers can be installed
  - package openblas-0.3.10-4.fc31.x86_64 obsoletes openblas-Rblas < 0.3.10-4.fc31 provided by openblas-Rblas-0.3.9-3.fc31.x86_64
  - package openblas-0.3.10-4.fc31.x86_64 obsoletes openblas-Rblas < 0.3.10-4.fc31 provided by openblas-Rblas-0.3.7-1.fc31.x86_64
  - cannot install the best update candidate for package openblas-0.3.9-3.fc31.x86_64
  - cannot install the best update candidate for package R-core-3.6.3-2.fc31.x86_64
 Problem 2: package R-yaml-2.2.1-1.fc31.x86_64 requires R-core, but none of the providers can be installed
  - package R-core-3.6.3-2.fc31.x86_64 requires openblas-Rblas, but none of the providers can be installed
  - package R-core-3.6.3-2.fc31.i686 requires libRblas.so, but none of the providers can be installed
  - package R-core-3.6.1-1.fc31.i686 requires libRblas.so, but none of the providers can be installed
  - package R-core-3.6.1-1.fc31.x86_64 requires libRmath(x86-64) = 3.6.1-1.fc31, but none of the providers can be installed
  - package openblas-0.3.10-4.fc31.x86_64 obsoletes openblas-Rblas < 0.3.10-4.fc31 provided by openblas-Rblas-0.3.9-3.fc31.x86_64
  - package openblas-0.3.10-4.fc31.x86_64 obsoletes openblas-Rblas < 0.3.10-4.fc31 provided by openblas-Rblas-0.3.7-1.fc31.i686
  - package openblas-0.3.10-4.fc31.x86_64 obsoletes openblas-Rblas < 0.3.10-4.fc31 provided by openblas-Rblas-0.3.7-1.fc31.x86_64
  - cannot install both libRmath-3.6.1-1.fc31.x86_64 and libRmath-3.6.3-2.fc31.x86_64
  - cannot install the best update candidate for package openblas-Rblas-0.3.9-3.fc31.x86_64
  - cannot install the best update candidate for package libRmath-3.6.3-2.fc31.x86_64
  - cannot install the best update candidate for package R-yaml-2.2.1-1.fc31.x86_64
 Problem 3: package R-core-3.6.3-2.fc31.x86_64 requires openblas-Rblas, but none of the providers can be installed
  - problem with installed package R-core-3.6.3-2.fc31.x86_64
  - package openblas-0.3.10-4.fc31.x86_64 obsoletes openblas-Rblas < 0.3.10-4.fc31 provided by openblas-Rblas-0.3.9-3.fc31.x86_64
  - package openblas-0.3.10-4.fc31.x86_64 obsoletes openblas-Rblas < 0.3.10-4.fc31 provided by openblas-Rblas-0.3.7-1.fc31.i686
  - package openblas-0.3.10-4.fc31.x86_64 obsoletes openblas-Rblas < 0.3.10-4.fc31 provided by openblas-Rblas-0.3.7-1.fc31.x86_64
  - package R-core-3.6.3-2.fc31.x86_64 requires libRblas.so()(64bit), but none of the providers can be installed
  - openblas-0.3.10-4.fc31.i686 has inferior architecture
  - package openblas-threads-0.3.10-4.fc31.x86_64 requires openblas = 0.3.10-4.fc31, but none of the providers can be installed
  - cannot install the best update candidate for package openblas-threads-0.3.9-3.fc31.x86_64
 Problem 4: package openblas-0.3.10-4.fc31.i686 obsoletes openblas-Rblas < 0.3.10-4.fc31 provided by openblas-Rblas-0.3.9-3.fc31.x86_64
  - problem with installed package openblas-Rblas-0.3.9-3.fc31.x86_64
  - package openblas-serial-0.3.10-4.fc31.x86_64 requires openblas = 0.3.10-4.fc31, but none of the providers can be installed
  - package R-xfun-0.16-1.fc31.x86_64 requires R-core, but none of the providers can be installed
  - package R-xfun-0.16-1.fc31.x86_64 requires R(stats), but none of the providers can be installed
  - package R-xfun-0.16-1.fc31.x86_64 requires R(tools), but none of the providers can be installed
  - package R-core-3.6.3-2.fc31.x86_64 requires openblas-Rblas, but none of the providers can be installed
  - package R-core-3.6.1-1.fc31.x86_64 requires openblas-Rblas, but none of the providers can be installed
  - package R-core-3.6.3-2.fc31.i686 requires libRblas.so, but none of the providers can be installed
  - package R-core-3.6.1-1.fc31.i686 requires libRblas.so, but none of the providers can be installed
  - package openblas-0.3.10-4.fc31.x86_64 obsoletes openblas-Rblas < 0.3.10-4.fc31 provided by openblas-Rblas-0.3.9-3.fc31.x86_64
  - package openblas-0.3.10-4.fc31.x86_64 obsoletes openblas-Rblas < 0.3.10-4.fc31 provided by openblas-Rblas-0.3.7-1.fc31.i686
  - package openblas-0.3.10-4.fc31.x86_64 obsoletes openblas-Rblas < 0.3.10-4.fc31 provided by openblas-Rblas-0.3.7-1.fc31.x86_64
  - package R-core-3.6.3-2.fc31.x86_64 requires libRblas.so()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package R-xfun-0.16-1.fc31.x86_64
  - cannot install the best update candidate for package openblas-serial-0.3.9-3.fc31.x86_64
========================================================================================================================
 Package                          Architecture           Version                          Repository               Size
========================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 libRmath                         x86_64                 3.6.1-1.fc31                     fedora                  122 k
Skipping packages with broken dependencies:
 R-core                           i686                   3.6.1-1.fc31                     fedora                   56 M
 R-core                           x86_64                 3.6.1-1.fc31                     fedora                   56 M
 R-core                           i686                   3.6.3-2.fc31                     updates                  57 M
 openblas-serial                  x86_64                 0.3.10-4.fc31                    updates                 4.3 M
 openblas-threads                 x86_64                 0.3.10-4.fc31                    updates                 4.5 M

Transaction Summary
========================================================================================================================
Skip  6 Packages
2 Likes

I don’t have this issue on Fedora 32.
You can try to report it and wait until it is solved, or upgrade to the next release.
Fedora 31 is supposed to be EoL in about a couple of months anyway.

There is an issue and an update in testing already:
https://bugzilla.redhat.com/show_bug.cgi?id=1872869
https://bodhi.fedoraproject.org/updates/FEDORA-2020-ccb3a757dc

1 Like