Rebooting wireless internet connection deactivated

Its strange that every time I reboot my laptop, the wireless internet connection does not work. Just like that the wireless button keep showing me that it is looking for network, as if there is no network in the area.

2 Likes
sudo tee /etc/NetworkManager/conf.d/00-mac-randomize.conf << EOF > /dev/null
[device]
wifi.scan-rand-mac-address=no
EOF
sudo systemctl restart NetworkManager.service

Randomize your MAC address using NetworkManager - Fedora Magazine

2 Likes

@vgaetera : can you explain a bit why randomising the MAC address should fix the issue? (we’re not quite sure of what the issue is yet)

@esesomar01 could you please look at your logs to see what it says when you try to connect to the network?

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

1 Like

It should disable MAC randomization when scanning Wi-Fi.
There are a few similar solved threads on the forum.

Power saving is another common cause of Wi-Fi-related issues to exclude:
How to keep internet connection connected without interruption - #4 by vgaetera

2 Likes

Ah, that makes sense. Totally worth trying. :+1:

2 Likes

I followed this and now cant connect to the internet at all. NetworkManager is enabled but failed (checking those with some of systemctl commands), checked the rest in usr/sbin to do --no-daemon
Couldn’t understand the docs given by fedora.
The pic

Shows me:
[devicename] wifi.scan-rand-mac-address=no
After that i type:
/usr/sbin/NetworkManager --no-daemon
And this shows up:
Failed to read configuration: /etc/NetworkManager/conf.d/00-mac-randomize.conf: Key file contains line "fedora" which is not a key-value pair, group, or comment

Remove that file, then restart NetworkManager and try again.
This time make sure to copy-paste the entire block of code as-is.

2 Likes

Thanks man that really helped. Magic :grinning_face_with_smiling_eyes: (my mind wondering how u know this)
Respect.

1 Like

One thing to always remember:
When someone provides you a suggested command it is intended that you run it as is and that you not make changes that “seem right”. The only time that does not apply is when an obvious part of the command line should be replaced by what applies you or your machine and is not generic.

3 Likes

Yes :+1:. I thought that the ‘[device]’ should be named with what the hostname is.
Learning from mistakes.
Thanks