Refresh Rate of Monitor

Thanks for the pointers.

It seems the initial step should be to make sure the displaycard + monitor combo do support a given display mode first. Which booting Windows to verify is one way to do it.

I read somewhere that certain monitor can do firmware update also.

I guess it will also be worth to check with manufacturer if updates are available or not.

Hi @gus67 I am using X-org display manager so, do you know how to?
I am not using Wayland right now

To add 1920x1080@60 to HDMI-1 for example (in theory) it works like

# use gtf to generate a modeline
gtf 1920 1080 60

  # 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
  Modeline "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync

# Add the new modeline to the server so it can be associated with outputs.
xrandr --newmode "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync

# Add the mode to the set of valid modes for an output.
xrandr --addmode HDMI-1 1920x1080_60.00

# switch mode
xrandr --output HDMI-1 --mode 1920x1080_60.00

If you have multiple modelines for a given resolution you can use –rate to select the one with the nearest refresh rate

xrandr --output HDMI-1 --rate 60

But, as always, this depends on your hardware/drivers.

1 Like

I am not sure why you want to reduce the refresh rate. My laptop has a screen with 144 Hz refresh, and I can connect an external monitor with 60 Hz refresh and both work well together.

Another tool that helps with refresh rates is xrandr.

@superadmin I’m on a Fedora 34 desktop using Gnome 40 and I get the following display options for my external monitor:


So if you can upgrade to Gnome 40, it might solve your problem (if it still exists).