Remote Desktop Gnome 42 to Android Tablet

I’m trying to use the Remote Desktop sharing to extend my laptop screen to my Android Tablet.
I tried enabling the sharing on Gnome but cannot connect with Microsoft Remote Desktop App on Android. Can someone explain clearly which username to use? The app seems to indicate that the username should be user@domain or domain/user, but the sharing settings speak of just a simple username.
The app mentions gateway settings. Why is this necessary when both devices are configured correctly to connect to the network?
Any help would be appreciated.

1 Like

RDP is the microsoft protocol while linux uses VNC to connect to a remote desktop.
For this you need the VNC server running on the device you want to connect to.

TigerVNC :: Fedora Docs

I read through the document and it is not clear what is the display number that I should use. I’m trying to extend my desktop to the vnc client on the tablet in this case.

I know that it’s been a half year since you asked, but when I tried to accomplish same setup I found out this thread in google.
(I’m connecting laptop with Fedora 36 desktop to DumbTV through HDMI, and wished to control it with my android phone without leaving a couch)
First of all @ilikelinux sugested VNC, and it’s a solution… old one solution.
Yes it was recommended through years, but it doesn’t work with Wayland. The same reason is why teamviewer, anydesk etc. won’t work.
You can still use it by switching from Wayland to X, what is easy btw (you can just choose it before startup on login screen).
However X has pros and cons.
It’s getting old, it’s why Wayland is even developed.
Wayland is fresh by contrast and not everything is Wayland compatible yet.

But comming back to your question.

  1. Go to: Settings → Sharing
  2. Turn on in right upper corner
  3. Go to: Remote Desktop
  4. Turn on: Remote Desktop & Remote Control
  5. In Authentication set a user name and password for rdp
    THIS IS NOT SAME AS YOUR USER NAME/PASS PAIR SIC(!)
    EVEN IF BY DEFAULT USER NAME IS SET TO THE SAME PASSWORD WOULD BE DIFFERENT.
  6. In Remote Desktop Adress you have something like:
    ms-rd://fedora.local

Everything is ok here.
Now download some RDP app for Android.
(I tried out Remote Desktop Menager and it works fine)
Just used fedora.local as host name, username that was set in Remote Desktop setting as username, and password that was set in Remote Desktop setting password as password.

All devices where in same wifi network.
Otherwise it would need public IP, VPN, or something.

I hope that when somebody would come here by googling, my answer would save him time I already lost to find out that it’s how to do it.