Remove Vivaldi or fix wrinkle

Newbie here. I didn’t note how I installed Vivaldi -2 instructions in the terminal and the install vivaldi-stable command. Quick. And the browser works as it should. But I keep getting the messages I’m attaching. I had this happen in an earlier install of Fedora 33, and I reinstalled the whole OS afresh, and made a point of not using the same method to install Vivaldi. No avail. Now the app will go with the “remove” command but the message remains.
I would appreciate help on how to either to fix the double entry in the configuration, or simply go Roman with the whole thing

[naioh@astra ~]$ sudo dnf update

[sudo] password for naioh:

Repository vivaldi is listed more than once in the configuration

Last metadata expiration check: 0:17:43 ago on Fri 26 Mar 2021 07:56:06 AM PDT.

Dependencies resolved.

Nothing to do.

Complete!

AND

[naioh@astra ~] sudo dnf repolist [sudo] password for naioh: Repository vivaldi is listed more than once in the configuration repo id repo name fedora Fedora 33 - x86_64 fedora-cisco-openh264 Fedora 33 openh264 (From Cisco) - x86_64 fedora-modular Fedora Modular 33 - x86_64 google-chrome google-chrome updates Fedora 33 - x86_64 - Updates updates-modular Fedora Modular 33 - x86_64 - Updates vivaldi vivaldi [naioh@astra ~]

HAVE A GOOD DAY AND HEALTH

In /etc/yum.repos.d you can find the file to delete.
In your case it must be something like vivaldi.repo

then dnf upgrade again

2 Likes

That says that for some reason you have two entries for that repo in /etc/yum.conf.d.
You should do a “sudo grep vivaldi /etc/yum.repo.d/*” and see what file names it gives you back. Then make certain that only one of the .repo files contains the entry for vivaldi

1 Like

Thank you. I get this, but disabling didn’t work, tells me “no match” for either of the names. The Vivaldi website recommends finding the files, but can’t just delete there. viv3
With my uneducated eyes I see that Chrome has what seems to be a similar double entry, but not message about it.

1 Like

you’ve got two google-chrome repo:

google-chrome.repo → where magic happens
google-chrome.rpmnew → some circumstances create this repo as a backup from the previous repo with this extension name doesn’t count as a valid repo name. that why you don’t get a message from there.

I suggest to you delete:

vivaldi-fedora.repo
vivaldi-snapshot.repo   # from latest release and not stable

I also have vivaldi and I don’t have this repo and this is the content, from vivaldi.repo:

[vivaldi]
name=vivaldi
baseurl=http://repo.vivaldi.com/archive/rpm/x86_64
enabled=1
gpgcheck=1
gpgkey=http://repo.vivaldi.com/archive/linux_signing_key.pub

Regards.,

2 Likes

Rid of it through root use of Nautilus -the point of it was not annoyance at seeing the message, but learning to navigate. Thank you

from the command line you can see which of those repos are enabled with " dnf repolist"

1 Like