Removing broken Virtualbox

Hi everyone,
I just installed Virtualbox from rpmfusion on Fedora 33.
It’s installed successfully, but I don’t know that you need to sign Virtualbox kernel module on secureboot enabled system for Virtualbox to run.
I don’t want to disable secure boot, and signing Virtualbox kernel module seems complicated to me.
So i just want to remove it.
Removing with ‘dnf remove VirtualBox’ only removing:

VirtualBox x86_64 6.1.16-2.fc33 @rpmfusion-free-updates 53 M

even though dnf history of installing Virtualbox is installing these packages:

Packages Altered:
Install elfutils-libelf-devel-0.182-1.fc33.x86_64 @updates
Install akmods-0.5.6-26.fc33.noarch @fedora
Install kmodtool-1-41.fc33.noarch @fedora
Install akmod-VirtualBox-6.1.16-2.fc33.x86_64 @rpmfusion-free-updates
Install VirtualBox-6.1.16-2.fc33.x86_64 @rpmfusion-free-updates
Install VirtualBox-kmodsrc-6.1.16-2.fc33.noarch @rpmfusion-free-updates
Install VirtualBox-server-6.1.16-2.fc33.x86_64 @rpmfusion-free-updates
Scriptlet output:
1 Created symlink /etc/systemd/system/multi-user.target.wants/akmods.service → /usr/lib/systemd/system/akmods.service.
2 Created symlink /etc/systemd/system/multi-user.target.wants/vboxdrv.service → /usr/lib/systemd/system/vboxdrv.service.

I tried dnf history undo but it gives me these errors:

Undoing transaction 642, from Thu 24 Dec 2020 08:06:07 AM WIB
Install elfutils-libelf-devel-0.182-1.fc33.x86_64 @updates
Install akmods-0.5.6-26.fc33.noarch @fedora
Install kmodtool-1-41.fc33.noarch @fedora
Install akmod-VirtualBox-6.1.16-2.fc33.x86_64 @rpmfusion-free-updates
Install VirtualBox-6.1.16-2.fc33.x86_64 @rpmfusion-free-updates
Install VirtualBox-kmodsrc-6.1.16-2.fc33.noarch @rpmfusion-free-updates
Install VirtualBox-server-6.1.16-2.fc33.x86_64 @rpmfusion-free-updates
Error:
Problem: package kmod-VirtualBox-5.9.15-200.fc33.x86_64-6.1.16-2.fc33.x86_64 requires VirtualBox-kmod-common >= 6.1.16, but none of the providers can be installed

  • conflicting requests
  • problem with installed package kmod-VirtualBox-5.9.15-200.fc33.x86_64-6.1.16-2.fc33.x86_64
    (try to add ‘–skip-broken’ to skip uninstallable packages)

I already tried with --skip-broken but still gives the same error.

What should i do? if i remove the packages one by one would it be a problem?

Thank you!

1 Like
sudo dnf history list kmod-VirtualBox
sudo dnf history undo ID
1 Like

sudo dnf history list kmod-VirtualBox

gives me:

No transaction which manipulates package ‘kmod-VirtualBox’ was found.

1 Like
sudo dnf remove kmod-VirtualBox
sudo dnf history undo 642
1 Like

sudo dnf remove kmod-VirtualBox

Sadly no kmod-VirtualBox:

No match for argument: kmod-VirtualBox
No packages marked for removal.
Dependencies resolved.
Nothing to do.
Complete!

and sudo dnf history undo 642
still gives the same results

1 Like

That’s weird, check the output:

sudo rpm --rebuilddb
sudo rpm -q -a "*VirtualBox*"
1 Like

sudo rpm --rebuilddb givesme:

error: can’t create transaction lock on /var/lib/rpm/.rpm.lock (Permission denied)

sudo rpm -q -a "*VirtualBox*" gives me:

VirtualBox-kmodsrc-6.1.16-2.fc33.noarch
VirtualBox-server-6.1.16-2.fc33.x86_64
akmod-VirtualBox-6.1.16-2.fc33.x86_64
VirtualBox-6.1.16-2.fc33.x86_64
kmod-VirtualBox-5.9.15-200.fc33.x86_64-6.1.16-2.fc33.x86_64

1 Like
sudo rpm -e kmod-VirtualBox-5.9.15-200.fc33.x86_64-6.1.16-2.fc33.x86_64
sudo dnf --skip-broken history undo 642
2 Likes