Removing item from autostart is reversed by system update

If you remove an autostart item like say Skype, it comes back again after doing a system update. So if you do a ‘dnf update’, then after rebooting the machine it autostarts Skype again even though you removed that from the autostart.

That may be possible, but we need more information to diagnose what is happening.

  • what version of Fedora are you using?
  • how did you install Skype?
  • how did you remove the autostart?

@FranciscoD:

  • what version of Fedora are you using?
    Fedora 31

  • how did you install Skype?
    I think it’s from https://repo.skype.com/rpm/stable/ (not at the machine just now), so via dnf

  • how did you remove the autostart?

    Go to: System Settings > Startup and Shutdown > Autostart

    Select ‘Skype for Linux’, then select ‘Remove’. Click Apply

1 Like

Hello.
Are you sure that there isn’t also an option on Skype that enable autostart? Sorry but I don’t use Skype anymore.

1 Like

mmh… maybe that’s it - it may be populating Autostart. I’ll check

1 Like

It probably is the app populating the file. The rpm only contains the one desktop file:

$ rpmls ./skypeforlinux-64.rpm  | grep desktop
-rw-r--r--  /usr/share/applications/skypeforlinux.desktop
drwxr-xr-x  /usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/desktop-idle
drwxr-xr-x  /usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/desktop-idle/build
drwxr-xr-x  /usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/desktop-idle/build/Release
-rw-r--r--  /usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/desktop-idle/build/Release/desktopIdle.node

Lately, I’ve not been using the rpm any more. The flatpak seems to work well and doesn’t require a system level installation, so I’ve been using that:

https://flathub.org/apps/details/com.skype.Client

3 Likes

Thank you! @FranciscoD

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.