Resolvectl connection timed out but google chrome working fine

After upgrade from Fedora 32 to Fedora 33 beta, the implementation of systemd-resolved leave me with brutally slow internet almost 0 speed connection for CLI tools and Firefox, but google chrome it’s working fine 200 Mbps, I made a mistake reporting the bug https://bugzilla.redhat.com/show_bug.cgi?id=1885095 because I find out that it isn’t anaconda’s fault, but that doesn’t resolve my problem, where I need to start to find out what the hell it’s happening?

1 Like

Please collect the following output:

systemctl --no-pager status systemd-resolved.service
resolvectl --no-pager status
grep -v -r -e ^# -e ^$ /etc/systemd/resolved.*
grep -v -e ^# -e ^$ /etc/nsswitch.conf /etc/resolv.conf
ls -l /etc/resolv.conf

Hi, thanks for you guidance, here are the results of the commands above

● systemd-resolved.service - Network Name Resolution
Loaded: loaded (/usr/lib/systemd/system/systemd-resolved.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2020-10-09 08:21:23 -05; 34min ago
Docs: man:systemd-resolved.service(8)
https ://www.freedesktop.org/wiki/Software/systemd/resolved
https ://www.freedesktop.org/wiki/Software/systemd/writing-network-configuration-managers
https ://www.freedesktop.org/wiki/Software/systemd/writing-resolver-clients
Main PID: 587 (systemd-resolve)
Status: “Processing requests…”
Tasks: 1 (limit: 8235)
Memory: 21.8M
CPU: 353ms
CGroup: /system.slice/systemd-resolved.service
└─587 /usr/lib/systemd/systemd-resolved

Oct 09 08:21:22 hp-13-ag0002la systemd[1]: Starting Network Name Resolution…
Oct 09 08:21:23 hp-13-ag0002la systemd-resolved[587]: Positive Trust Anchors:
Oct 09 08:21:23 hp-13-ag0002la systemd-resolved[587]: . IN DS 20326 8 2 e06d44b80b8f1d39a95c0b0d7c65d08458e880409bbc683457104237c7f8ec8d
Oct 09 08:21:23 hp-13-ag0002la systemd-resolved[587]: Negative trust anchors: 10.in-addr.arpa 16.172.in-addr.arpa 17.172.in-addr.arpa 18.172.in-addr.arpa 19.172.in-addr.arpa 20.172.in-addr.arpa 21.172.in-addr.arpa 22.172.in-addr.arpa 23.172.in-addr.arpa 24.172.in-addr.arpa 25.172.in-addr.arpa 26.172.in-addr.arpa 27.172.in-addr.arpa 28.172.in-addr.arpa 29.172.in-addr.arpa 30.172.in-addr.arpa 31.172.in-addr.arpa 168.192.in-addr.arpa d.f.ip6.arpa corp home internal intranet lan local private test
Oct 09 08:21:23 hp-13-ag0002la systemd-resolved[587]: Using system hostname ‘hp-13-ag0002la’.
Oct 09 08:21:23 hp-13-ag0002la systemd[1]: Started Network Name Resolution.
Oct 09 08:22:38 hp-13-ag0002la systemd-resolved[587]: Using degraded feature set UDP instead of UDP+EDNS0 for DNS server 192.168.1.253.

Global
LLMNR setting: resolve
MulticastDNS setting: no
DNSOverTLS setting: no
DNSSEC setting: no
DNSSEC supported: no
Fallback DNS Servers: 1.1.1.1
8.8.8.8
1.0.0.1
8.8.4.4
2606:4700:4700::1111
2001:4860:4860::8888
2606:4700:4700::1001
2001:4860:4860::8844

Link 2 (wlo1)
Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
DefaultRoute setting: yes
LLMNR setting: yes
MulticastDNS setting: no
DNSOverTLS setting: no
DNSSEC setting: no
DNSSEC supported: no
Current DNS Server: 192.168.1.253
DNS Servers: 192.168.1.253
DNS Domain: ~.

Link 3 (virbr0)
Current Scopes: none
DefaultRoute setting: no
LLMNR setting: yes
MulticastDNS setting: no
DNSOverTLS setting: no
DNSSEC setting: no
DNSSEC supported: no

Link 4 (virbr0-nic)
Current Scopes: none
DefaultRoute setting: no
LLMNR setting: yes
MulticastDNS setting: no
DNSOverTLS setting: no
DNSSEC setting: no
DNSSEC supported: no

[Resolve]

/etc/nsswitch.conf:passwd: sss files systemd
/etc/nsswitch.conf:shadow: files sss
/etc/nsswitch.conf:group: sss files systemd
/etc/nsswitch.conf:hosts: files mdns4_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] myhostname dns
/etc/nsswitch.conf:services: files sss
/etc/nsswitch.conf:netgroup: sss
/etc/nsswitch.conf:automount: files sss
/etc/nsswitch.conf:aliases: files
/etc/nsswitch.conf:ethers: files
/etc/nsswitch.conf:gshadow: files
/etc/nsswitch.conf:networks: files dns
/etc/nsswitch.conf:protocols: files
/etc/nsswitch.conf:publickey: files
/etc/nsswitch.conf:rpc: files
/etc/resolv.conf:nameserver 127.0.0.53
/etc/resolv.conf:options edns0 trust-ad

lrwxrwxrwx. 1 root root 39 Oct 8 10:37 /etc/resolv.conf -> …/run/systemd/resolve/stub-resolv.conf

1 Like

This resolver doesn’t seem to support the modern protocol.
Try to disable automatic DNS and configure it manually.
Using a major public DNS provider is preferable.

1 Like

Thanks mate, I change the DNS in my router as you suggest and everything works fine right now

1 Like