Restore Fedora boot after installing Linux Mint

lsblk shows this:

nvme0n1            465,8G                                  
├─nvme0n1p1 vfat     200M /boot/efi                        
├─nvme0n1p2 ext4   149,8G /                                
├─nvme0n1p5 ext4     100G                                  
├─nvme0n1p6 ext4       1G                                  
└─nvme0n1p7 btrfs  214,8G /media/cip/fedora_localhost-live fedora_localhost-live

Gparted:

enter image description here

This configuration has the following story: on a GPT partition (laptop with UEFI BIOS) first was installed a Windows 10 system at the beginning of the drive. That had created I think three small partitions and a big one. (At the present these have been replaced with the Linux Mint ones.) After installing Windows I have copied a Solus Linux partition from a different drive (without creating a uefi partition; the Solus partition is still present, it is the big one in the middle as shown in gparted); immediately after that I have installed Fedora 34 letting the system to make a default installation, which has created 2 partitions at the end of the drive, the last one btrfs. For a while I have used Fedora (with its boot loader), Solus and Windows at the same time.

But then I have removed the Windows 10 partitions at the beginning of the drive and in place I have installed Linux Mint. Prompted to create a uefi partition, I have done that too: the Mint partitions are the first two at the beginning of the drive.

Now Linux Mint has installed the grub boot loader and Solus is accessible, but not Fedora. It is absent from the boot list, updating grub or installing Grub Customizer in Mint doesn’t help, Fedora remains absent.

The btrfs drive is accessible in Mint and can be mounted, but updating grub doesn’t show Fedora:

sudo update-grub
[sudo] password for cip:       
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found theme: /boot/grub/themes/Stylish/theme.txt
Found linux image: /boot/vmlinuz-5.4.0-58-generic
Found initrd image: /boot/initrd.img-5.4.0-58-generic
Found Solus (4.2) on /dev/nvme0n1p5
Adding boot menu entry for UEFI Firmware Settings
done

Was Fedora maybe dependent on one of the small partitions created by Windows 10 (which were in place when Fedora was installed)?

Or maybe creating a Linux Mint UEFI partition conflicts somehow with that created by Fedora?

How could I make Fedora visible in the Linux Mint boot loader – or otherwise have a boot loader with all the three Linux systems?

To my experience, as long as grub can show up the Boot Menu, then the content of the EFI partition is not that important.

What we need to do, is to create the suitable grub boot menu entry to book Fedora.

When using fedora, running grub2-mkconfig can detect other bootable Linux / Windows. But saving the output, then grub can use the details to show the correct boot entries.

Please see what is available in Mint that is similar to grub2-mkconfig under Fedora.

1 Like

If grub2-mkconfig is a tool to administer and edit grub boot loader list and such, as said in the question, Grub Customizer is a debian/ubuntu GUI tool for that, but normally update-grub command should find Fedora and add it to the boot loader list. But as said in the question that doesn’t happen. I am looking for a solution from Mint but not only. Could reinstalling grub from live usb onto the Fedora partition fix this? On which of the 2 Fedora partitions should then grub be installed? And can grub2-mkconfig be used from Fedora live usb to restore the Fedora grub?

https://docs.fedoraproject.org/en-US/quick-docs/bootloading-with-grub2/#restoring-bootloader-using-live-disk

This is how to reinstall grub bootloader for Fedora

But be carefull and do back up your existing bootloader config as a precaution.

3 Likes

My “pro” tip: When having multiple Linux distros on one host, always update grub from one and only one of them. If you add a new distro, do not allow it to re-install (to the drive) and update grub. After the installation has completed, go back to the one distro and update grub from it.

You can ignore this advice, but doing so will lead to both foul ups and confusion.

2 Likes

I’ve always thought that not installing grub with a system would leave me with no grub at all. And do main distros have an option not to install grub during system installation?

Yes. I even made a video demo a while back showing how to skip installing the bootloader with Fedora Linux. In my case, I was demoing how to install systemd-boot which has some design features for supporting multiple operating systems. Unfortunately, systemd-boot hasn’t been widely adopted by the distros (yet).

video link: uefi partitioning

3 Likes

Maybe I don’t understand exactly what you are trying to do. Are you trying to have more than one Linux distro installed on a single host? That was what I thought, but re-reading your post, I’m not sure.

If another distro on a multi-boot system has already installed and configured grub, installing a second or third distro does not affect that. As to not allowing a new installation to install and configure its grub, sometimes you have to fight it to make it not do so. If you cannot avoid that, just boot back to the distro you want to control grub from, and reinstall and reconfigure grub from it.

I have managed as many as six distros side-by-side this way in the past. I no longer distro hop that way, though. I have settled down to one distro per host PC.

1 Like

Yes, I am still focused on a multi-boot configuration (in fact I’m looking for a Plasma-centered distro for long-term use, and am about to try in parallel Fedora and Solus with that desktop, while also having Windows on the same host.) I was not aware that a new system can be easily installed without a new grub. That’s very useful. Thanks.

I imagine this is the solution, and I’ll mark it as such. (I wasn’t able to use it myself, I had errors, it’s all too complicated, I gave up Fedora for the moment, I think I’ll try it later, maybe without dual boot.)