Rpm-ostree error while insalling or refreshing (zchunk error)

Hi, I am currently running silverblue 32 on VM because I want to make sure things work before I switch to it completely. After installing, I did my first upgrade with rpm-ostree upgrade and it has no problem. After rebooting I try to install fish with rpm-ostree install fish but got this error

rpm-ostree install fish
Checking out tree 640eb70… done
Enabled rpm-md repositories: fedora-cisco-openh264 updates fedora
rpm-md repo ‘fedora-cisco-openh264’ (cached); generated: 2020-03-17T20:10:45Z
rpm-md repo ‘updates’ (cached); generated: 2020-05-24T01:33:43Z
Updating metadata for ‘fedora’… done
error: Updating rpm-md repo ‘fedora’: cannot update repo ‘fedora’: Yum repo downloading error: Downloading error: Unable to initialize zchunk file repodata/b7e1566c87075299c4a199737b341e7d15fbf1a4d49c4c2cbe43368437b02c47-comps-Everything.x86_64.xml.zck: Unable to set zchunk file descriptor for repodata/b7e1566c87075299c4a199737b341e7d15fbf1a4d49c4c2cbe43368437b02c47-comps-Everything.x86_64.xml.zck: Unable to find multipart download range
; Last error: Zchunk error: Unable to find multipart download range

I try to rpm-ostree refresh-md but the same error come out.
I’m not sure what’s the problem. Can someone help me please? Thanks.

Any updates on this.
Or how we can disable zchunk on fedora silverblue.
This is giving me a headache. Any help appreciated.

Thank you.

Well. Take this as a supposition.
In a regular Fedora install, the in /etc/dnf/dnf.conf the zchunk=False option should prevent dnf to use zchunk data.
rpm-ostree uses libdnf as well, but libdnf (again, take this as a supposition, I’m not a developer of these bits) doesn’t honor such option: zchunk is always enabled.

There is a change in the libdnf code: https://github.com/rpm-software-management/libdnf/pull/998, but as far as I know it hasn’t still landed in the Fedora libdnf package.

Said that, you know, Fedora Silverblue is not as wide used as a regular Fedora Edition/Spin is. The number of users is still limited, and it is still under heavy development. So it has a dedicated forum you can find here: https://discussion.fedoraproject.org/c/desktop/silverblue
Try to ask there.

thank you for the help.
Unfortunately, I’ve tried the configuration, but no luck.
I’ll try the silverblue forum.

Thanks again for the helpful reply. :+1:

Indeed, it doesn’t work because right now (again, I’m not the developer) the use of zchunk is bundled in the code and it doesn’t take into account the option in the dnf.conf file. I think that this is the same issue with packagekit in regular Fedora.
I think that we have to wait the next version of dnf

However, I still have to understand why zchunk doesn’t work in some circumstances.
@ramasentani, @changwuf31 what kind of internet connection do you use? (ADSL, mobile, …?)

For the records: https://discussion.fedoraproject.org/t/howto-disable-zchunk-on-rpm-ostree/22440