RStudio missing Quarto in Fedora RPM

Hello everyone,

I’m relatively new to Fedora, have been using it for a few months now, currently on F37. I installed RStudio using the software application from the fedoraproject RPM. Unfortunately, it is missing the option to open or create Quarto documents (a scientific publishing system based on markdown - creating documents should be possible through File > New File > Quarto Document).

The version seems to be the most recent one (2022.12.0+353) compared with the official download page. When I download and install the version from the Posit download page (exactly same version number), the option exists and I can work with Quarto documents normally.

So this could be the solution to my problem, but weirdly, a few days after installing the RPM from Posit, all shortcuts to start the software (from dash, search, app grid) vanish without me doing anything (at least anything I’m aware of). This has never happened with any other software before.

At first I thought the software had miraculously uninstalled, but dnf list installed still shows rstudio.x86_64 2022.12.0+353-1.fc37

So my questions are:

  1. Why is the RStudio version in the Fedora repository different from the “official” one despite having exactly the same version number?
  2. Any idea why all the application icons disappear?
  3. How to make them reappear (reinstalling the software works, but this is not a viable solution considering that I’d have to do it every few days)? And at the least (probably a beginner’s question): How do I start RStudio without having an app icon to click on? Simply typing rstudio in the terminal offers me to install the rstudio-desktop package which I don’t want because [see above :wink:].

The problem with Quarto missing has been mentioned in the RStudio Community but without a solution. I tried installing Quarto manually which was successfull (tried /usr/local/bin/quarto check) but didn’t change anything about RStudio integration.

I’d be happy about any advice or idea you might come up with. Thanks in advance!

Kind regards
Sebastian

1 Like

The best place to file this is in Bugzilla, but as a temporary workaround in the meantime, I maintain some Rstudio container images at work that include Quarto:

Some of the course images, that are also public, include more tex libraries, etc, that you may or may not need, or you can easily make your own downstream image from it.

Thanks for your help Scott, I really appreciate it! I’ll have a look at your images.
For reference: bug report has been filed (2162538 – RStudio package missing Quarto despite being most recent version)

Kind regards,
Sebastian

1 Like