Rtl8188ee not found after install

I used the live usb product to install. While running live, my wifi was detected and working. First install wifi was working. I upgraded packages after install. Wifi no longer worked. I went back the the live usb and wifi worked. I reinstalled with base install, wifi not working second time. It still works with the live usb.

With some effort I rebuilt and installed latest drivers (Wifi adapter not found rtl8723de). It still does not work. WTF? Why does it work with live usb and not the drivers? I have toggled the airplane mode so it is not that.

Hi @geekie, welcome to our community! This really sounds odd - what exactly do you mean by “no longer worked”? Are there no wifis shown, or is the graphics not available? What is the output of sudo iwconfig if you have a freshly installed system (without the rebuilt drivers)? And are there any logs in dmesg or journalctl regarding the drivers, the kernel or the network?

This is certainly frustrating. I reinstalled a third time, WiFi was working. I installed a number of packages. I did not install these packages the first install but did a dnf update. This time no updates.

rpm -ivh rpmfusion-free-release-31.noarch.rpm
rpm -ivh rpmfusion-nonfree-release-31.noarch.rpm
dnf install @kde-desktop
rpm -Uvh trinity-repo-14.0.7-1.fc31.noarch.rpm
dnf install trinity-tdebase -y
dnf install tlp tlp-rdw -y
dnf install google-chrome -y
dnf install obs-build -y
dnf install dkms git gcc gcc-c++ kernel-headers kernel-devel make -y

I then rebooted and there are no visible networks.

$ iwconfig
wlo1 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off
Power Management:off

lo no wireless extensions.

enp3s0 no wireless extensions.

$ dmesg|grep rtl
[ 26.452808] rtl8188ee: rtl8188ee: FW Power Save off (module option)
[ 26.452846] rtl8188ee: Using firmware rtlwifi/rtl8188efw.bin
[ 26.454835] ieee80211 phy0: Selected rate control algorithm ‘rtl_rc’
[ 26.455270] rtlwifi: rtlwifi: wireless switch is on
[ 26.657135] rtl8188ee 0000:02:00.0 wlo1: renamed from wlan0

You can see a difference in journalctl for the initial install with localhost vs spare hostnames:

[root@spare ~]# journalctl |grep rtl81
Apr 03 10:53:33 localhost.localdomain kernel: rtl8188ee: rtl8188ee: FW Power Save off (module option)
Apr 03 10:53:33 localhost.localdomain kernel: rtl8188ee: Using firmware rtlwifi/rtl8188efw.bin
Apr 03 10:53:33 localhost.localdomain kernel: rtl8188ee 0000:02:00.0 wlo1: renamed from wlan0
Apr 03 10:53:52 localhost.localdomain NetworkManager[928]: [1585925632.6647] rfkill0: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:02.4/0000:02:00.0/ieee80211/ph
y0/rfkill0) (driver rtl8188ee)
Apr 03 11:28:38 localhost.localdomain kernel: rtl8188ee 0000:02:00.0 wlo1: disabling HT as WMM/QoS is not supported by the AP
Apr 03 11:28:38 localhost.localdomain kernel: rtl8188ee 0000:02:00.0 wlo1: disabling VHT as WMM/QoS is not supported by the AP
Apr 03 13:54:12 spare kernel: rtl8188ee: rtl8188ee: FW Power Save off (module option)
Apr 03 13:54:12 spare kernel: rtl8188ee: Using firmware rtlwifi/rtl8188efw.bin
Apr 03 13:54:12 spare kernel: rtl8188ee 0000:02:00.0 wlo1: renamed from wlan0
Apr 03 13:54:31 spare NetworkManager[1083]: [1585936471.9056] rfkill0: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:02.4/0000:02:00.0/ieee80211/phy0/rfkill0) (dr
iver rtl8188ee)

It seems like my ifconfig script should be correct:

ifcfg-mynet
::::::::::::::
ESSID=mynet
MODE=Managed
KEY_MGMT=WPA-PSK
SECURITYMODE=open
MAC_ADDRESS_RANDOMIZATION=default
TYPE=Wireless
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=dhcp
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME=mynet
UUID=0bc3b6bb-27bf-49f1-b216-cbfc463aa804
DEVICE=wlo1
ONBOOT=yes

@geekie I am not sure if I understand your setup: did you modify any configuration manually, like your ifcfg script? Because you do have NetworkManager running there, that usually doesn’t like manual configuration…

Hi,

As liquidat says, you should be able to configure the connection via NM, but if your are using ifconfig; I think its missing DHCPV6C=yes

If that doesn’t help, whats the output of

lspci -v

Thanks Tom.

No, I have not modified anything. I only assumed NM was using the ifcfg script.

lspci -v

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter (rev 01)
DeviceName: Shanks2
Subsystem: Hewlett-Packard Company Device 81bf
Flags: bus master, fast devsel, latency 0, IRQ 44
I/O ports at 3000 [size=256]
Memory at f0c00000 (64-bit, non-prefetchable) [size=16K]
Capabilities: access denied possibly not run as root
Kernel driver in use: rtl8188ee
Kernel modules: rtl8188ee

Hi,

Whats the output of:

sudo modprobe rtl8188ee

Thanks Tom.

Is there output expected:

[root@spare ~]# lsmod|grep rtl
rtl8188ee 106496 0
rtl_pci 32768 1 rtl8188ee
rtlwifi 98304 2 rtl_pci,rtl8188ee
mac80211 974848 3 rtl_pci,rtl8188ee,rtlwifi
cfg80211 835584 2 rtlwifi,mac80211
[root@spare ~]#
[root@spare ~]#
[root@spare ~]# modprobe -v rtl8188ee
[root@spare ~]#

Hi,

If there were any issues with the module or if secure boot had been enabled if would have flagged.

Sorry I’ve been re-reading the topic to try and work out whats going on. This would suggest that one of in installl packages has caused a conflict. All I can suggest is try reinstalling again, install these one at a time with a reboot inbetween each, hopefully it will be come clearer as to whats causing the conflict. From there hopefully will be able work out what needs to be done to fix the issue.

Thanks Tom.

My apologies if I confused you. A little bit about my background…I work in a data center and I’ve performed hundreds of linux installations. I can customize if necessary. I’m not a big fan of NetworkManager but for laptops, I just let it do its thing. I have changed no configurations. This was the sequence of events:

Install #1 - Live USB Wifi works. Installed to hard drive, Wifi works. dnf update, reboot, No networks found.

Install #2 - Live USB Wifi works. Installed to hard drive, no networks found.

Install #3 - Live USB Wifi works. Installed to hard drive, Wifi works. Some packages installed. Reboot, no networks found.

It’s difficult to believe any of the packages installed had a conflict with my Wifi driver. They were all pretty standard packages and should not have had any direct hardware interaction. I have seen updates in Fedora 30 break my VPN, but we are just looking at vanilla install here.

Thanks for helping.

Hi,

So does wifi still work if you reboot before installing any packages?

Thanks Tom.

As install #2 indicates, there were no networks found after install and no packages added.

HI,

This suggests on your 3rd attempt, that it working after the install. So are you installing the live packages in the live environment or are booting in to the installed environment and then installing the packages.

Tom.

The Live USB is removed after reboot. Yes it works on the initial install, inconsistently. Nothing about these packages, post install, should interfere with the operation of the network adapter. Do you know what config file guides the operation of this device? It’s possible it gets changed at some point. Maybe I can compare it with what is on the live usb.

Also, what is it in journalctl that happens after the initial install that does not happen after reboot:
Apr 03 11:28:38 localhost.localdomain kernel: rtl8188ee 0000:02:00.0 wlo1: disabling HT as WMM/QoS is not supported by the AP
Apr 03 11:28:38 localhost.localdomain kernel: rtl8188ee 0000:02:00.0 wlo1: disabling VHT as WMM/QoS is not supported by the AP

HI,

Not sure its config files, I would guess there in /etc/modprobe.d/

I think this may come down to the kernel, I think the live update stick pulls updates during install. If that is correct, I suspect the environments are running different kernels. You can confirm with a uname -r issued in both live and installed environment.

I’m running out of ideas here, I know the the kernel driver is buggy; but it should work with rtlwifi_new. Although it looks like the driver for rtl8188ee hasn’t been updated in over a year. At his point I would considered raising a issue with the developer, can be done here

From looking at the current issues, there does seem to be issue with rtl8188ee and the stable branch, one user has suggested using the extended branch driver:

Thanks Tom.

There definitely some oddball things going on. I moved it to another location, to a different WAP, without shutting down or closing the lid to sleep and it detected many different wifi routers. I simply rebooted in this new location and when it came up, it no longer detected any networks. I am going to chalk this up to either a kernel issue or possibly old hardware that is failing. I will try a different kernel or distro to see if there is any change. I appreciate your help.

1 Like