Rtw_8822ce Wlan not working since Kernel 5.17 / Fedora 36 and 37

Im using Fedora Silverblue on a Huwaei Matebook 13 with the wlan chipset rtw_8822ce; Before i was using fedora workstation. After a kernel upgrade my Wlan stopped working. I can connect to my router but i get no working internet connection. So Workstation wasn’t usable for me anymore. I installed Fedora silverblue an pinned the default installation version with kernel 3.17 and my wifi and internet connection is working fine.

Today i upgraded to the fedora silverblue 37 beta in hopes of a working wlan. but the bug is persistent. And i renders this machine useless. Here my dmesg output hope i fix is coming soon.

Blockquote
[ 25.696946] wlp1s0: send auth to 38:43:7d:68:d2:a0 (try 1/3)
[ 25.700272] wlp1s0: authenticated
[ 25.701386] wlp1s0: associate with 38:43:7d:68:d2:a0 (try 1/3)
[ 25.738808] wlp1s0: RX AssocResp from 38:43:7d:68:d2:a0 (capab=0x511 status=0 aid=1)
[ 25.739170] wlp1s0: associated
[ 25.832521] wlp1s0: Limiting TX power to 14 (17 - 3) dBm as advertised by 38:43:7d:68:d2:a0
[ 25.832600] IPv6: ADDRCONF(NETDEV_CHANGE): wlp1s0: link becomes ready
[ 30.191185] usb 1-2: USB disconnect, device number 2
[ 30.191372] rndis_host 1-2:1.0 enp3s0f3u2: unregister ‘rndis_host’ usb-0000:03:00.3-2, RNDIS device
[ 35.590639] rfkill: input handler enabled
[ 37.064913] Lockdown: systemd-logind: hibernation is restricted; see man kernel_lockdown.7
[ 37.736814] rfkill: input handler disabled
[ 43.059374] rtw_8822ce 0000:01:00.0: failed to get tx report from firmware

Welcome to ask.:fedora:edora @dondurrito

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

I guess you meant Kernel 5.17.x ?
If you have RTW_8822ce you will need to install the driver separately … search for RTW_8822ce with search option on the top.

1 Like

I found this post which indicates that the geolocation service somehow interferes with the wifi, and turning it off seems to fix it:

Could you try that perhaps and see if it helps?

Here’s another post that suggests one needs to install the driver:

1 Like

OMG, Turning of geolocation fixed the bug. Thank you very very much. I already filed a kernel bug report …

1 Like

Awesome! Could you edit your post here to note the kernel bug? We can then mark your post as the solution for others to see too.