Ruby 2.7 on Fedora 34

Do you guys know of any repo where I can get Ruby 2.7?
I’m trying to run Jekyll 3.9, which is the only one compatible with Github Pages, but it won’t work on Ruby 3 (shipped with Fedora).

dnf module list shows ruby 2.7 as being an option on my Fedora Linux 34 workstation. I haven’t tried it though.

1 Like

That command led me to these two pages:
https://docs.fedoraproject.org/en-US/modularity/installing-modules/
https://bugzilla.redhat.com/show_bug.cgi?id=1669502#c1

And the command needed was:
sudo dnf module install ruby:2.7/default

Thank you very much!

2 Likes