Run Gnome as Root in Server 30

OK, I’ve searched the interweb and found the classic cure for running Gnome as the root user with no luck. Yes I know this is not recommend, but I am OK with the risks. startx works fine if logged in as a regular user, but fails when logged in as root.

I’ve reviewed the issue of commenting out the line in gdm-password file, but that line does not exist. I’m not a pam expert so I cannot figure out what change needs to be made. Not sure if it is a pam, GDM, or some other change that needs to be made.
Any help would be appreciated.

Interesting, no answers. Just installed Centos 8 and can log in to Gnome as root, no problem!
At this point latest versions of Fedora are of no use to me. Lab test setup, takes too much to su every time I want to change something.

There are no responses because it’s not a good idea. There is no reason to run (nearly all) graphical applications as root, especially the window manager, because that means everything is root.

For terminal applications, use sudo and for graphical applications, most integrate with polkit to request elevated permissions when necessary.

I’ve been in IT for 19 years and fully understand the implications. I’m interested in how this blocking of root running gnome is done. Especially knowing the fact that Centos7 and 8 do not have the same restrictions. It is not done by the built in settings in gdm/gdm-password and likely done in pam, but I can’t find it. If there is another method, I’d like to know and understand since it could be used for restricting other programs.
I appreciate you reply.