Russian roulette with system closing programs

hi

i can’t figure out the systems logic when it comes to when or why the usual suspects get terminated. what i mean is for example just now when i was using scrcpy answering driving theory questions on my android all of a sudden my fedora system closed firefox. why?!

it usualy closes firefox if i open too many tabs but right now i wasn’t even using firefox and it had been running for an 1h or so. other times it’s eiskaltdc++ qt closes seemingly randomly without any notification telling be about it.

i have 16 gigs of ram, is this some way to strict memory managment? I’ve not had this be the case when using Linux Mint or Windows 10. can i stop this default termination behavior?

Are your 16 gig of ram (plus swap or swap file or zram) all used up when this happens?
Could be initiated by Changes/EnableEarlyoom - Fedora Project Wiki

check with watch free -h

also log files should tell you if early oom kicked in and killed some processes.

3 Likes

For Fedora 34, it is systemd-oomd:

https://fedoraproject.org/wiki/Changes/EnableSystemdOomd

3 Likes

I’ll check later today. this morning another strange thing that happens but rarely, i have 3 monitors and sometimes fedora switched back to the default wallpaper on one of the monitors… just FYI…

Let’s try keeping different issues separated - feel free to open a new topic regarding the display issue.

2 Likes

ok i skimmed through some of the url you gave, it’s pretty technical for my understanding of what i read.

however, if you guys thinks it’s out of memory is the swapfile in other linux distro the same as zram0 in fedora? because selecting it says it has a linuxswap type. is there, this setup seems kinda different from what ubuntu (or more precisely what i used before, Mint) uses.

would you suggest following this guide?

not before knowing what you problem actually is.

how much ram does your machine have?

how much RAM is usually available? Frequently run free -h from a terminal during a typical workload and see what it says. There are also the System Monitor tool from Gnome which tells you the same thing.

Please also post the output of /sbin/zramctl

If it turns out that your memory is under pressure, I would create an additional swap file and setting its priority to something lower than the zram.

1 Like

I’ve got 16 gigs of ddr4, how do i show output of /sbin/zramctl i can’t double click it to open. I’m not sure how much of my ram is usually used, I’ll keep the overview tab of system monitor up on one of the computer monitors at all times and see for a day or 2 and get back to you.

1 Like

open a terminal (like Gnome Terminal), and type zramctl, then paste the output here as “preformatted text”, that’s a formatting option in the tool bar above.

Do the same with free -h, once you have started all the usual programs that you run in parallel.

1 Like

during the night at some point eiskaltdc++ was closed by the time i woke up. this time it didn’t however also happen to firefox which is sometimes also closed by the time i wake up. as you can see from the output i did follow the guide i asked about and did increase by 2gb the swap yesterday evening but that apparently didn’t solve it.

[premier69@premier69-pc ~]$ zramctl
NAME       ALGORITHM DISKSIZE   DATA  COMPR  TOTAL STREAMS MOUNTPOINT
/dev/zram0 lzo-rle        10G 511.9M 133.8M 140.1M      16 [SWAP]
[premier69@premier69-pc ~]$ 

Question is if tthe program you mentioned crashed or if it was killed by systemd-oomd. Check your overnight logs to find out more.

1 Like

Which log? where?

1 Like

Your system logs. Please see:

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

1 Like