Samba-winbind 32 bit version

Hello,

I wanted to install Battle.net using Lutris in Fedora 31, but the needed dependency samba-winbind-clients.i686 is missing on my system and could not find it in the repositories. However, the 64 bit version seems to be present. Where did the 32 bit version go?

:thinking: Strange.
If you look here: https://koji.fedoraproject.org/koji/buildinfo?buildID=1423008, it was correctly built for every architecture.
If you look here: https://dl.fedoraproject.org/pub/fedora/linux/releases/31/Everything/x86_64/os/Packages/s/ the i686 rpm is not available (as well in https://dl.fedoraproject.org/pub/fedora/linux/updates/31/Everything/x86_64/Packages/s/)

Honestly I don’t know why.

Out of curiosity, I submitted the question to the devel mailing list.

And this is the answer:

It’s not a library, so it definitely won’t be in the 64-bit repo. The 32-bit repos have been discontinued, so the only way to get it now is from koji.

This is a consequence of this change: https://fedoraproject.org/wiki/Changes/Noi686Repositories

So the only way to install it is:

sudo dnf install \
https://kojipkgs.fedoraproject.org//packages/samba/4.11.4/0.fc31/i686/samba-winbind-clients-4.11.4-0.fc31.i686.rpm \
https://kojipkgs.fedoraproject.org//packages/samba/4.11.4/0.fc31/i686/samba-common-libs-4.11.4-0.fc31.i686.rpm

Please note that you should update it by hand whenever there is a new version of the package.

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.