Scilab don't work in KDE 32!

After try dnf install scilab as superuser and don’t work, Scilab was downloaded from oficial site and unpacked in the /opt/ dir and when try to run:

./scilab

in the binary dir show this:

/usr/bin/chcon: failed to change context of '/opt/scilab-6.1.0/bin/scilab-bin' to ‘unconfined_u:object_r:execmem_exec_t:s0’: Operation not permitted
Error: Cannot chcon 'scilab-bin' /usr/bin/chcon: failed to change context of '/opt/scilab-6.1.0/bin/scilab-cli-bin' to
‘unconfined_u:object_r:execmem_exec_t:s0’: Operation not permitted
Error: Cannot chcon 'scilab-cli-bin'
scilab-bin: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory

Please help, how can get scilab work?

@robbykz, what error did you get from dnf install scilab?

The errors from the /opt installation are coming from SELinux.

libtinfo.so.5: cannot open shared object file: No such file or directory

You need that file.  There is –provides option for dnf, to find out what package provides some file (man dnf).

@vits95 the error get when run dnf install scilab is:

Last metadata expiration check: 0:49:26 ago on Sat 02 May 2020 07:11:33 AM.
Error: 
Problem: conflicting requests
  - nothing provides jeuclid needed by scilab-6.0.2-2.fc31.x86_64
  - nothing provides jogl2 needed by scilab-6.0.2-2.fc31.x86_64
  - nothing provides jrosetta needed by scilab-6.0.2-2.fc31.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

when run dnf -provides libtinfo.so.5 show me:

No such command: libtinfo.so.5. Please use /usr/bin/dnf --help
It could be a DNF plugin command, try: "dnf install 'dnf-command(libtinfo.so.5)'"

Should be dnf provides no dash.
Use -C if you don’t want to update the cache each time.

1 Like

@grumpey Please could give an example of the -C use?

sudo dnf -C provides libtinfo.so.5

1 Like

@grumpey thanks was useful I already have runned dnf install libtinfo.so.5 what’s show your example command, installed libtinfo.so.5 but unfortunately when run scilab from bin dir show this:

/usr/bin/chcon: failed to change context of '/opt/scilab-6.1.0/bin/scilab-bin' to ‘unconfined_u:object_r:execmem_exec_t:s0’: Operation not permitted
Error: Cannot chcon 'scilab-bin'
/usr/bin/chcon: failed to change context of '/opt/scilab-6.1.0/bin/scilab-cli-bin' to ‘unconfined_u:object_r:execmem_exec_t:s0’: Operation not permitted
Error: Cannot chcon 'scilab-cli-bin'
scilab-bin: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory

still can’t open scilab :sob:

pd. when installed libtinfo.so.5 installed only i686 dependencies

1 Like

Probably relevant:

Scilab did not build in Fedora 32, and because the maintainer did not have the resources to maintain it, it was orphaned. So, that’ll explain why it cannot be installed using dnf.

https://bugzilla.redhat.com/show_bug.cgi?id=1800077

So, using the version from the official website is the right way to go here.

Also, the command to install libtinfo.so.5 wasn’t quite complete. For a 64 bit (x86_64) system, it’ll be provided by both the x86_64 and the i686 package:

sudo dnf whatprovides '*/libtinfo.so.5'
ncurses-compat-libs-6.1-15.20191109.fc32.i686 : Ncurses compatibility libraries
Repo        : fedora
Matched from:
Filename    : /usr/lib/libtinfo.so.5

ncurses-compat-libs-6.1-15.20191109.fc32.x86_64 : Ncurses compatibility libraries
Repo        : fedora
Matched from:
Filename    : /usr/lib64/libtinfo.so.5

If you are using a 64 bit build of scilab, you’ll need to install the 64 bit library (shared object) package:

sudo dnf install ncurses-compat-libs  # will install x86_64 by default

#or

sudo dnf install /usr/lib64/libtinfo.so.5  # full path points to the x86_64 package

Observe the difference:

$ sudo dnf install libtinfo.so.5
Dependencies resolved.
==============================================================================================================================================================================================================================================
 Package                                                       Architecture                                   Version                                                         Repository                                                 Size
==============================================================================================================================================================================================================================================
Installing:
 ncurses-compat-libs                                           i686                                           6.1-15.20191109.fc32                                            fedora                                                    341 k
Installing dependencies:
 glibc                                                         i686                                           2.31-2.fc32                                                     updates-testing                                           3.3 M
 libgcc                                                        i686                                           10.0.1-0.11.fc32                                                fedora                                                     95 k
 libstdc++                                                     i686                                           10.0.1-0.11.fc32                                                fedora                                                    657 k

Transaction Summary
==============================================================================================================================================================================================================================================
Install  4 Packages

Total download size: 4.4 M
Installed size: 18 M
Is this ok [y/N]: N
Operation aborted.

$ sudo dnf install /usr/lib64/libtinfo.so.5
Last metadata expiration check: 0:49:29 ago on Sat 02 May 2020 21:55:02 BST.
Dependencies resolved.
==============================================================================================================================================================================================================================================
 Package                                                         Architecture                                       Version                                                          Repository                                          Size
==============================================================================================================================================================================================================================================
Installing:
 ncurses-compat-libs                                             x86_64                                             6.1-15.20191109.fc32                                             fedora                                             324 k

Transaction Summary
==============================================================================================================================================================================================================================================
Install  1 Package

Total download size: 324 k
Installed size: 1.0 M
Is this ok [y/N]: N
Operation aborted.

I haven’t thought about the selinux issue yet. Perhaps install setroubleshoot and see what the alerts suggest. A workaround for the time being is to set selinux to permissive:

sudo setenforce 0

But, this should be treated as a workaround only :slight_smile:

2 Likes