Screen brightness is not maintained after reboot

Hey guys! I know there is a thread on this forum in the f32 section about this, but I don’t understand and I don’t even know the best way to proceed to modify this adjustment in Grub or in the System. After System reboot, the brightness level always returns to maximum.

I have the same problem on Fedora 35 Silverblue. Online resources either mention changing /sys/class/backlight/intel_backlight/brightness or by changing GRUB setting, both of which are immutable locations on Silverblue.

I ran systemctl status systemd-backlight@backlight:intel_backlight.service to get the output:

systemd-backlight@backlight:intel_backlight.service - Load/Save Screen Backlight Brightness of backlight:intel_backlight
     Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static)
     Active: failed (Result: exit-code) since Tue 2022-04-12 21:05:15 IST; 14h ago
       Docs: man:systemd-backlight@.service(8)
    Process: 675 ExecStart=/usr/lib/systemd/systemd-backlight load backlight:intel_backlight (code=exited, status=238/STATE_DIRECTORY)
   Main PID: 675 (code=exited, status=238/STATE_DIRECTORY)
        CPU: 2ms

Apr 12 21:05:15 fedora systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:intel_backlight...
Apr 12 21:05:15 fedora systemd[675]: systemd-backlight@backlight:intel_backlight.service: Failed to set up special execution directory in /var/lib: Read-only file system
Apr 12 21:05:15 fedora systemd[675]: systemd-backlight@backlight:intel_backlight.service: Failed at step STATE_DIRECTORY spawning /usr/lib/systemd/systemd-backlight: Read-only file system
Apr 12 21:05:15 fedora systemd[1]: systemd-backlight@backlight:intel_backlight.service: Main process exited, code=exited, status=238/STATE_DIRECTORY
Apr 12 21:05:15 fedora systemd[1]: systemd-backlight@backlight:intel_backlight.service: Failed with result 'exit-code'.
Apr 12 21:05:15 fedora systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:intel_backlight.

Can anyone tell me how to fix this correctly on Silverblue?

Found a solution that works for me.

The systemd service just has to be restarted once and then it seems to work fine. Copying the command here for easy access:

sudo systemctl restart systemd-backlight@backlight:intel_backlight.service
1 Like