Screen Sharing in Fedora Workstation 31 will not remember my VNC password

Hello, I have installed Fedora 31 Workstation (default desktop, Gnome). I setup “Screen Sharing” (the built-in/default VNC server) and it does work once I configure it, but every time the machine reboots the password is lost and the Screen Sharing setting reverts to this:

I think this might be due to a keychain “unlock” issue because I see this when I go to fix the issue after each reboot:
Fedora_login_keychain_broken

Please tell me how to permanently fix this issue. Thank ou

Hi @crimsonkida, just to verify that I understand your approach here: you do want to use the screen sharing option to be automatically on, even after a reboot? TBH I am not even sure if that is supported.

I recommend to open a bug report with Gnome directly and that way figure if this is a bug. If you do that, please post the link to the bug report here.

Yes. It is supposed to work.

I think that @crimsonkida has some issues with the keyring. But I’m unsure.

Do you have automatic login enabled?

Yes, I had auto-login enabled. I disabled autologin, and VNC works as expected now, but the VNC server does not start until I physically login. I would call this a bug, yes.

Is there a fix?

Yes, this is correct. The keyring issue is present due to auto-login being enabled (doesn’t happen when I manually login). Is there a fix?

This is not a bug. It is a feature :slight_smile:
I mean that Vino (if I’m not wrong this is the vnc implementation used by GNOME screen sharing) is user based.
In order to start vnc before a user log in, you have to use another solution (not GNOME screen sharing), but I’m not of help here.

The only other option I see here is to enable auto-login, and also change the keyring password to empty, that might do it.

But this is a highly insecure configuration, and thus I second the idea to change to a VNC solution independent of the Gnome login.

3 Likes

I work in Enterprise SaaS Support, so I fully get the bug vs feature thing, lol. :wink:

Of course it’s not a 1-to-1 comparison, but the “VNC Scraping Server” on Ubuntu 19 works 100% as expected for this. I had hoped GNOME on Fedora could be just as good. :frowning_face:

Thank you, @liquidat. This machine is essentially serving as a “display” monitor in my home office so it’s absolutely inconsequential if it’s not secured. I will try making the keyring empty…

I second the idea to change to a VNC solution independent of the Gnome login.

To my knowledge, it is not possible to have a VNC Server that interacts with the desktop that is independent of the GNOME login. Since the sole purpose of this machine to act as a physical “monitor” I cannot use something like TigerVNC, unless it were a VNC “scrapping” server which apparently does not exist for Fedora (only Ubuntu).

All joking aside, this literally is a bug. It crashes the GNOME desktop when I try and VNC in with auto login enabled:

Ok, then best is to set up a bug report. Please post the link to the bug report here as well so that others can follow up on it!