Screen Sharing issues, after LAN cable plugged on top of working wifi

Continuing the discussion from Fedora 32 workstation sharing screen not working after upgrade from fedora 31:

Following the above post, I can connect from my Desktop Fedora to my Laptop Fedora, while:

Laptop is:

  • Fedora 33 fresh install
  • connected to Wifi to internal 192.168.1.0/24 subnet
  • LAN cable unpluged, to a Valid IP

While screen sharing is connected, I connect the LAN cable to my Laptop. Then:

  • My active VNC session disconnected immediately
  • VNC reconnect to Internal IP failed
  • VNC connection to Valid IP failed

As checked, ping to Laptop’s both Internal and Valid IP works.

Extra issues with the prompts with “New connections must ask for access”.

  1. Connection prompt timeout in about 2s, otherwise the prompt will be gone, and
  • there is no “dot” to the left of the date/time to indicate new notifications waiting
  • even manually checking on the notification panel, click on the connection request entry, there is no way to accept the connection
  • while that request entry is here, client side reconnect always got "Server closed connection.
  • Need to remove that entry before new connections possible (with a new prompt come up in the Laptop side)
  1. When the notification panel is open, no way to accept new connection, while client side still “Connecting to server”.

I will say Screen Sharing on Wayland session is possible now, because of the new PipeWire Video backend. But due to Gnome’s poor notification handling (of connection request prompts), it is hard to use it (with ask for access) without knowing the existing limitations.