Screensaver's blank screen active while disabled

Hello,

with xfce4-screensaver-4.16.0-2.fc34.x86_64 (on F34) I have a strange problem. I disabled energy saving and screensaver, but it’s still blanking my screen after X minutes. Any ideas how I can troubleshoot this? (I tried a reinstall of the package without success)

Regards,
Paddy

Have you tried checking your “blank” settings.

xset q

Should provide you with the information like:

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0

My bet is that if blanking was off:

xset s noblank

Issue would not appear. If that helps, then let’s try searching how this can be accomplished natively, through XFCE GUI. :slight_smile:

1 Like

Both values are set to “no”. But Screensaver insists in blanking the screen. My agreement with it is to set the time for blanking high and let it be.

On my previous F34 installation I didn’t have this problem.

Did you check xfce power settings and the screensaver settings?

Indeed.

Why did you think this would help?

https://www.freedesktop.org/software/systemd/man/logind.conf.html

Can you try to modify the PowerSaving options directly in /etc/systemd/logind.conf to see if it helps?

I was not able to find docs related to screensaver settings via /etc/systemd/logind.conf. Could you explain a bit more detailed how this is done?