Severe screen tearing after rotating a monitor 90 degrees

I’m using Fedora 30 KDE with Intel integrated graphics. While working on a project with many files (i.e. long vertical lists) I decided to rotate one of my two monitors 90 degrees counterclockwise, after which I rotated the display in software via System Settings > Display and Monitor > Displays > Orientation > 90° Clockwise. However, I now notice diagonal screen tearing while scrolling on my non-rotated monitor and vertical screen tearing on my rotated monitor. These tearing issues disappear when I undo the rotation of the monitor.

Is there a fix for this? Even enabling full screen repainting in the compositor vsync settings doesn’t fix it.

Edit: I went through a few of the setup steps on the Arch Linux Intel graphics page and set enable_guc=2 in the i915 module configuration, but that didn’t fix anything. Creating an X configuration file (/etc/X11/xorg.conf.d/20-intel.conf) with TearFree enabled fixed the tearing problem, but it created a whole new problem with the non-rotated display being scaled weirdly and forced my session to X11 instead of Wayland. I’d like to keep using Wayland rather than switch back to X, so any suggestions would be appreciated.

Hi Bob,
I have no any idea to how fix screen tearing, because when i will change screen scale i get like your problem.
but about that configuration you made/changed, /etc/X11/ is for X not Wayland. if you see your screen tearing will be gone with that changes in X, so use X instead of Wayland. and report this.

@Ghasem thanks, I’m aware that configuration files in /etc/X11 are for X rather than Wayland, but at this point I’m willing to try anything. I’m surprised that it booted me straight into an X session though.

I’ll report this as a bug if nobody else has a solution.

1 Like

I just switched from Ubuntu 18.04 to Fedora 30 and the screen tearing appered.
I do have 2 vertical monitors and they tear vertically when moving things around.
As I have KDE spin, I am running under X11.

I got realy better results by installing :
sudo dnf install xorg-x11-drv-amdgpu -y

KDE composer is OpenGL 3.1 and automatic VSYNC.
On Vega 64, so for intel GPU you will have to try xorg-x11-drv-intel and see if it works.