Shipped versions of PHP and Zabbix (frontend) are incompatible

Problem

Fedora 35 ships version 8.0 of PHP and version 5.0 of Zabbix,
but as stated in Zabbix 5.0 Documenation: Requirements this combination
is not supported. The PHP software for the Zabbix frontend
needs to have version 7.2 or later, but not 8.

Cause

PHP was updated in the Fedora Linux repositories to the latest version, and there isn’t a Zabbix version that is ready for that.

Related Issues

Bugzilla report: #2020292

Workarounds

Under discussion.

1 Like