Silverblue F37 - mystery alert sound that just won't die

This is something of an oddball issue, but I suspect there may be something of greater interest going on under the hood here.

I rebased my Silverblue install onto the 37 tree right before the original planned release date. Since then, GNOME’s alert sound - the little clip that plays when you try to backspace too far in the terminal, for example - has inexplicably been stuck on the old, removed default drip.ogg - which, according to my repeated invocations of find, exists approximately nowhere on my disk.

Setting the alert sound in the GNOME control panel to one of the new options (such as “Hum”) has no effect; the new sound does play when you select it, but every other application is still somehow using “Drip,” including both Flatpaks and traditional packages.

Any ideas as to where this audio file could possibly be hiding/why my applications seem drawn to it like moths?

1 Like

I’m having the same issue after updating to Fedora 37, but I’m on Fedora Cinnamon not Silverblue/Gnome. I hope someone can figure out where this sound is coming from, it’s really annoying.

I just started noticing this on Fedora 36 MATE. How is backspace in terminals, documents, etc getting that drip sound all of a sudden while system sound effects is disabled in settings??

system_sounds

Does disabling the terminal bell stop any of it?

Disabling the terminal bell stops it in the terminal, but anywhere else that defers to the system alert sound (such as the Firefox Crtl-F dialog) will still exhibit the issue.

Edit: Also, I was able to fix it on one of my machines by doing… something in gconf/gsettings. I flipped the flag back and forth between a custom value and default a few times and it magically went away…

gsettings set org.gnome.desktop.wm.preferences audible-bell false

1 Like

Oh, yeah that shuts it up. Switching it back on still yields the incorrect sound, but I doubt that would fix it.

Yes, that stopped the sound in the terminal. I thought for sure I had it disabled in the preferences before. I wonder if somehow preferences have been overwritten.

There is also org.mate.Marco.general audible-bell.

I set both to false, not sure why they were true, but I still hear it. Is a reboot or session restart required to apply?

I didn’t need one on gnome but it can’t hurt

Sound still present after a reboot.

Try creating a new user and check the sound.

Can you check the workaround in this bug , mate-volume-control : alert level not working · Issue #99 · mate-desktop/mate-media · GitHub

Thanks

1 Like

This worked!

I first had to install pavucontrol, launch it, and in the Playback tab move the System Sounds slider around once. Then in MATE’s sound preferences I have to Mute the Alert volume. Just setting the sound theme to “No sounds” is oddly not enough.

See the difference in having the sound slider and Mute button enabled compared to above:

alert_volume_fixed