Since upgrade to Fedora 34 GNOME, no more updates install on shutdown?

When I was using Fedora 33 GNOME, almost every time when shutting down a message was telling me that updates will be installed during the shutdown, with the possibility to cancel this action by un-ticking a checkbox.

Here is the message I’m talking about (note, I do not speak German, I found this screenshot using a google image search):

image

Since I upgraded to Fedora 34 GNOME, this message never appears anymore, and I do not have the possibility to automatically install updates on shutdown anymore.

Is there any way to re-enable this?

1 Like

Software center updates tab missing - #2 by vgaetera

Thank you for your answer, unfortunately my “Updates tab” never went missing in my case, and I had already checked before posting that org.gnome.software.download-updates was correctly set to true in dconf. No luck :frowning:

1 Like
systemctl status packagekit.service packagekit-offline-update.service; \
rpm -q -a PackageKit\* gnome-software\* | sort; \
gsettings list-recursively org.gnome.software | sort

What is the output?

So I have been experiencing the same issue and given your instructions this is what I have:
https://paste.centos.org/view/468415b1

Does that help?

1 Like

Try to perform the following and reboot:

# Restore user settings
gsettings reset-recursively org.gnome.software

# Clean user and system cache
rm -f -R ~/.cache/gnome-software
sudo rm -f -R /var/cache/PackageKit

# Restore service startup settings
sudo systemctl preset-all

# Fix SELinux labels
sudo fixfiles -F onboot

If the issue persists check for related error messages:
Viewing logs in Fedora :: Fedora Docs

2 Likes

This solved the issue for me. However, I would advise to be careful at this step:

# Restore service startup settings
sudo systemctl preset-all

Make sure to re-enable the non-default services you might be using.

2 Likes

Still nothing on my end.

I’ve applied all the steps from @vladislav two days ago, but unfortunately my OS still does not offer me to install updates on shutdown.

I’ve looked at PackageKit logs, but no errors or warnings there.

But I did find something strange: each time I select “shutdown” in the top-right GNOME shell menu (which makes the pop-up message show up to ask confirmation), the following lines appear in my logs:

mai 20 11:04:13 knodel gnome-shell[2251]: endSessionDialog: No XDG_SESSION_ID, fetched from logind: 2
mai 20 11:04:14 knodel gnome-session-binary[2227]: Entering running state
mai 20 11:04:14 knodel gnome-shell[2251]: Ignored exception from dbus method: Gio.IOErrorEnum: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dio_2derror_2dquark.Code19: L’opération a été annulée

(Sorry about the french bit)

Actually, it seems this fix did persist. The update prompt showed up only once, the shutdown after I did the steps, and never again.

I have the same problem.
I’m hesitant to try the suggested solutions in fear of breaking something else, and because others are mentioning it isn’t working anyway…

2 Likes

Here is a screenshot image from DuckDuckGo of the popup with checkbox that came up when restarting or shutdown on Fedora 33 GNOME 3.x
Is there a safe solution to enable this option? It appears to be an issue in previous GNOME versions https://bugzilla.redhat.com/show_bug.cgi?id=1805265

gnome restart

the updates were not prepared (pre-downloaded in the background automatically) was a bug in gnome-software 40. Fixed in 40.2 released today: Software is not preparing any updates? (#1253) · Issues · GNOME / gnome-software · GitLab

2 Likes

@sobek Thanks for the pointer, that is great news. Looking forward to 40.2 in Fedora then :).

1 Like