Skype hanging on fedora 32?

Anyone else seeing skypeforlinux locking up after sending a few messages on Fedora 32?

How did you install Skype?

name=skype (stable)
baseurl=https://repo.skype.com/rpm/stable/
enabled=1
gpgcheck=1
gpgkey=https://repo.skype.com/data/SKYPE-GPG-KEY

I just added the skype repo, and installed with dnf.

Can you try the flatpak (containerized app) from flathub?

https://flathub.org/apps/details/com.skype.Client

Install: flatpak install flathub com.skype.Client

Run: flatpak run com.skype.Client

2 Likes

Exact same behaviour unfortunately…

I would create a new user and see if the problem persists.

Unfortunately, the msteams update didn’t fix the problem. It still hangs.

My skype update told me “The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing ‘dnf clean packages’.
Error: GPG check FAILED”

I’m not sure if that update will fix the current issue… there is a thread about that on the microsoft website:

https://answers.microsoft.com/en-us/skype/forum/all/skype-for-linux-64-rpm-package-is-not-signed-how/0b04dd59-2dca-4338-9169-ab70b7722c5d

I can’t confirm the Skype hangs, as I haven’t been using it lately, but the skypeforlinux package update not installing due to it not being signed has persisted for a couple of weeks now. Incredible.

There are several more threads addition to the one linked above:
https://answers.microsoft.com/en-us/skype/forum/all/package-skypeforlinux862083-1x8664rpm-is-not/db999121-2339-49b5-a039-23f49352f78d
https://answers.microsoft.com/en-us/skype/forum/all/package-skypeforlinux862083-1x8664rpm-is-not/724dc2ae-b8ce-4710-b87f-e9bf7bfa5e32
https://answers.microsoft.com/en-us/skype/forum/all/skype-for-linux-rpm-package-v862083-1-is-not/6033495a-4dfd-4df2-b868-a27459148d0a

I don’t want to disable the GPG check and install an unsigned package, so I’ve been using sudo dnf upgrade --refresh -x skypeforlinux.

I still can’t believe the (lack of) MS employee response and how long it’s taking to resolve what seems to be a simple issue.

As of today, skypeforlinux finally installs properly without disabling GPG check.

Now you can check if you still get hangs on the latest version (8.62.0.85-1).

1 Like

Hangs remain unfortunately, it may be slightly better but it’s particularly bad if I click into another window and then click back to skype. It just grays out completely and you get the ‘Terminate application’ dialog.