Skyrim special edition not use Nvidia graphics on optimus laptop

Hi all, I’m facing a problem. I’ve downloaded skyrim special edition on my Laptop, after setting the correct launch option in Steam (for fixing the NPC audio) it work, is playable but the frames are low. I have added the environmental variable for use my nvidia to the launch option (__NV_PRIME_RENDER_OFFLOAD=1) but the game it doesn’t start on the nvidia. For other games this is the only things that i do to utilize the descrete card (like kerbal space program).
Any suggestions?

Note that skyrim start with a window used to change some settings and to start the game, then it opens a second program to load the current save and than it launches the game in a third window. Is possible that those three are different programs and only the first is running on the nvidia?

My specs:
Cpu: i5 5200U
dGPU: nvidia Ge force 920m
Os: fedora 32

1 Like

Does anyone know how to launch an application using open source nvdia driver using terminal?

Hi @vgaetera, this is not related to my issue, but you can use the DRI_PRIME=1 environmental variable before the command. :wink:

Perhaps, there’s a reason, why DRI_PRIME=pci-xxxx_xx_xx_x in the switcherooctl output.