Small problem with the terminal | missing asterisks while enter sudo password

I’m not sure if this is the proper section, and if it was already reported. There’s a small problem with the “terminal” that started after doing a dnf update.
Every time that the terminal asks me for a password (sudo), it doesn’t allow me to type in. Like, it gets blocked, and I have to press enter and type fast before the terminal asks again.
It also happens with other “GUI’s”.
Despite that’s what I can do at the moment, is kinda annoying.

Do you have Fedora Workstation or Fedora spin ?
In Fedora Workstation the user is sudoer otherwise you need to use the root password :

Try : sudo su and type the user password … if it said not allowed, you need root password safer
Try : su and type the SuperUser ( root ) password …
And you will know which cmmand & password to use…

On Fedora workstation with user as sudoer you will need to type :
either :
sudo dnf update -y; Enter + user password
Or
sudo su Enter + user password
dnf update -y; Enter + user password

On Fedora spin with distinct user and SuperUser ( root ) you will need to type :
either :
su -c' dnf update -y; ' Enter + user password you can add commands beetween the ’ ’
Or
su Enter + SuperUser ( root ) password;
dnf update -y; Enter + user password you can add commands after the ;

1 Like

I’m using Workstation (x86_64). I think it could be that the asterisks aren’t displayed.
@geplinux
By the way, what’s that command for?
I’ve tried recently, and doesn’t work. It still asks for my administration password.

Then you will need to type :
Either :
sudo dnf update -y; Enter + user password
Or
sudo su Enter + user password
dnf update -y; Enter
Or
sudo su -c' dnf update -y; ' Enter + user password you can add commands beetween the ’ ’

@geplinux
Oh, I see what you’re talking. No, the problem is not that I can’t update dnf.

I don’t know how to explain it, but is like: exactly when that message shows (password for user:), I can’t literally write on it (typing my password, which I already know).
This problem started after I used “updated dnf”. Before that, I could type on it without problem.

Sorry … then quite more complicated …
Did you try to type your password in Gedit and copy it then paste it ( CTRL+SHIFT+V ) in the terminal ?

@geplinux
I tried, and doesn’t work :frowning:
It also happens with the accesibility keyboard.
It get’s blocked, and I can only manage to type after pressing enter, before it shows up that I didn’t enter a password.

Strange
During the boot procedure can you select a previous version of Fedora ( the second line for instance )
If yes, does it change anything ?

@geplinux
How I can do that?
If you’re talking about the interface version which I am logged (modern gnome, old gnome, gnome with Xorg), it still happens.

Simply reboot and select an older version of your Fedora than the current one,
Sorry for the picture I found it on the web…

If it works I would simply dnf clean packages; dnf clean all; dnf -y update; dnf -y upgrade; reboot;

@geplinux ok ok, but, how? I need to press a key before starting the computer? or I need to put a command to reboot and select the version?

Sorry I’m not on my Fedora I’ve just started it not avalaible as I have a script forcing update at starting up… ( I’ll send you Fedora’s screenshot soon ) but that is the same with RHEL but older kernel…

Firtst you need to check if you have diffrents version of kernel :

rpm -qa kernel\*

Here we can see that we have there is 3 core left :

rpm -qa kernel\* | grep core

( For info : You can chose the limit of kernel to keep and chose to keep one kernel

installonly_limit=5; dnf mark install kernel-I-Want-to-keep;

But that is not the purpose of this thread :slight_smile: )

@geplinux I will share screenshots later (Right now I’m not at my computer), because i’m not sure what kernel should I choose.

After that, I have to use the grub menu, right?

Exactly, you are right : during the starting up GRUB asks you which version to start…

In my case I will use Fedora Linux (5.17.12-300.fc36.x86_64) 36 (Workstation Edition) Just the previous one ( not to old )

1 Like

@geplinux Hi again. I managed to access grub. I could only change back to a very recent kernel.


Is the one saying (5.17.5).
Unfortunately, the problem still persists :confused: So it must be another thing from the system.

Here’s a capture from the terminal, btw:

Captura desde 2022-06-28 20-33-56

Ok, I gess I do understand your problem … As i can see, you are coming from a debian based Linux
(You wrote several times apt).

You want the asterisks back when you type in the password … that you can count how many characters you typed in already, right?

This should solve your problem:

p.s.
Some Linux operating systems do not show this asterisks by default. If you have someone behind you while typing the password the amount of characters can be counted. This gives a hint of your password length.

3 Likes

@ilikelinux OMG, thanks! It works (finally).
I never hear about that fact (at least, from videos). I find it kinda confusing for new users.
As you can guess, I came from Ubuntu (Mint) and rarely I touched the terminal for some things.

BTW, welcome to ask.:fedora:edora @unnepad

I started with LMDE from Linux Mint. It takes a while till you get used with dnf and the other fedora/RHEL tools. But as soon you get used you will not want to go back to Mint.

About apt, you could make you an alias like
alias apt="dnf --help"
and put this to you ~/.bashrc file on the end. So every-time you type apt it will give you the overview of the dnf command to remind you that you are on Fedora Linux :grinning:

1 Like

I wrote “apt” because it was just to test the “sudo” part of the command :smile:
Anyways, thanks. Fedora looks promising, tbh.

1 Like