Software center is unresponsive before restart

My software center is unresponsive without restarting. I first have to restart and then the updates and everything will be displayed and I can look around at the different software options available.

Most of the time I am forced to reboot to install updates so I have to restart twice if I choose to update via the software center and at least once if I want to browse around the software center and install something new.

I can update via the terminal just fine but it is inconvenient that I have to restart before I can do anything in the software center.

Does anyone have any idea what I can do to fix this?

As far as I know that’s the default for updates to restart into kind of a safe mode then restart when updates are finished.I have auto update turned off and use dnf upgrade in the terminal.

Software center almost always recommends a restart, but it isn’t usually necessary. More worrisome is that Software Center hangs for you. Seems you’re comfortable at the command line, so if you have a terminal window launched, does ‘top’ seem to show that software center is looping, or IO bound, or ??

With top running. I opened the software center and just clicked on updates. Not sure if there are any yet this morning as it is still early. But the process shows for maybe 2 minutes and then it is disappears.

Software center is still open. The wheel that spins with updates has stopped spinning and if I click on Explore, and then any application, it will say loading application details and this does not change.

Still no process displaying in top once it disappears.

OK, so software center is stuck trying to get package information, apparently. Try cleaning the cache information; methods are shown in this prior post: Gnome Software package installation constantly pending.
Let’s see if that clears your issue.

I cleaned the cache, even uninstalled gnome-software and reinstalled. It works just fine right after a restart so I will have to update later if it continues to hang.