Software screen freeze after upgrade to f36

Hi,
I have a Dell XPS laptop with an Intel graphics card that I recently upgraded to Fedora 36. After the upgrade I noticed an issue with the software MedeA I have been using. The MedeA screen freezes when I load a molecular structure. I contacted their tech support who said the issue is most probably with the Intel graphics. Any suggestions on how to fix this problem? Thanks.

While you may be reaching the limit of capabilities for an integrated graphics card, you might be able to increase the memory allocation for the video card in your BIOS settings. If you have a discrete video card (as I imagine you probably do on an XPS), you can try using that instead. If you’re using Gnome, right click on the launcher and if you see an “Launch with Discrete Graphics” option, click that. If you’re not using Gnome, you can try starting your program with DRI_PRIME=1.

If you’re still stuck, please give us the output of inxi -SMCIG in preformatted or code block format.

1 Like

Thank you. We tried your suggestion but it does not seem to work. We even tried to install nvidia-drivers and even legacy ones but none of them seem to work.
Here is the output of inxi -SMCIG :

% inxi -SMCIG

System:

Most: localhost Kernel: 5.19.6-200.fc36.86_64 arch: X86_64 bits: 64

Desktop: Cinnamon v: 5.2.7 Distro: Fedora release 36 (Thirty Six)

Machine: Type: Portable System: Dell product: XPS 15 9530 v: A09 serial: ‹superuser required>

Mobo: Del1 model: XPS 15 9530 V: A09 serial: ‹superuser required>

UEFI: Dell V: A09 date: 07/30/2015

CPU:

Info: quad core model: Intel Core 17-4712HQ bits: 64 type: MT MCP cache:

L2: 1024 KiB

Speed (MHz): avg: 1225 min/max: 800/3300 cores: 1: 800 2: 800 3: 800

4: 800 5: 2709 6: 2296 7: 798 8: 800

Graphics:

Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: N/A

Device-2: NVIDIA GK107M [GeForce GT 750M] driver: N/A

Device-3: Realtek Integrated_Webcam_HD type: USB driver: N/A

Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.3 driver: X:

loaded: vesa unloaded: fbdev, modesetting gpu: N/A resolution: 3200Ă—1800~90Hz

OpenGL: renderer: Ilvmpipe (LLVM 14.0.0 256 bits) v: 4.5 Mesa 22.1.7

Info:

Processes: 290 Uptime: 2m Memory: 15.53 GiB used: 1.42 GiB (9.2%)

Shell: tcsh inxi: 3.3.19 /home /madhu 102 %

Hi Scott,
Does the output of inxi -SMCIG suggest what the problem is? Thanks.