[solved, but no answer] Fedora-Mate with Nvidia Optimus only shows DM through HDMI

So, I did a fresh install of Fedora Mate. I have an optimus laptop, so I had to install nvidia-drivers and I did that through rpmfusion. I also installed nvidia-prime-select, which is a fork of FedoraPrime.
This setup works fine, with the exception that when I turned on the nvidia-card, I have to have an external monitor plugged into the hdmi, or else I get just a black screen in tty1. I’ve tried other DE, tweaking the DM and the greeter, but I can not get the nvidiacard to show the login on my laptopscreen if I happen to not have my monitor plugged in. If I turn on the intel-card, everything works fine, but sometimes I just need my nvidiacard.
Any suggestions on how to solve this?

1 Like

You can copy the monitor configuration from your user to GDM user.

I use mate, which comes with lightdm by default. Does this also work with other DM?

1 Like

try this from arch wiki .
https://wiki.archlinux.org/index.php/NVIDIA_Optimus#LightDM

Allright, so I was planning to do what @youssefmsourani suggested today, but when I started up my pc, I noticed that this problem literally solved itself (I now see my DM, even with one monitor). I’ve did lot’s of things between the time it worked and now, but none of them are related to GPU’s, screensettings or whatever.
Sadly, I can’t explain why this is solved.

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.