[SOLVED] F34 pipewire works, alsa recognizes sound card however pipewire doesn't see it

As explained in the title, independently both pipewire and alsa works as expected.

$ aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

This is the list of devices that alsa sees.

$ systemctl --user status pipewire
● pipewire.service - Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
             └─00-uresourced.conf
     Active: active (running) since Fri 2021-04-30 22:42:44 CEST; 8min ago
TriggeredBy: ● pipewire.socket
   Main PID: 1486 (pipewire)
      Tasks: 4 (limit: 19052)
     Memory: 13.0M
        CPU: 1.277s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             ├─1486 /usr/bin/pipewire
             └─1505 /usr/bin/pipewire-media-session

Apr 30 22:42:44 amstel systemd[1474]: Started Multimedia Service.

$ systemctl --user status pipewire-pulse
● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; enabled; vendor preset: disabled)
     Active: active (running) since Fri 2021-04-30 22:42:44 CEST; 8min ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 1487 (pipewire-pulse)
      Tasks: 2 (limit: 19052)
     Memory: 22.2M
        CPU: 553ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─1487 /usr/bin/pipewire-pulse

Apr 30 22:42:44 amstel systemd[1474]: Started PipeWire PulseAudio.

This is what systemctl shows for pipewire services.

And this is the only device shown in Gnome settings.
Bluetooth headset works without a problem.
Any pointers?

1 Like

OK right after I have posted I noticed that you need to plug a cable in to have it shown in Gnome settings.
I consider this solved.

1 Like