Some Apps Not Working In Second Monitor

I’m fairly new to fedora but this issue has been there since I installed it. Some apps don’t work on my second monitor. What I mean is it gets incredibly slow, to the point where nothing works. I use a laptop and those same apps work perfectly fine on the laptop screen. The apps I’ve notived these issues with are: Vivaldi, VLC, Videos, and a flathub game called Flare: Empyrean Campaign. Other apps like firefox or anything else (including games) seem fine. If additional information is required, let me know and I’ll post it below.

EDIT: I found out that discord also has the issue.

If you have an integrated video card (ie, Intel graphics), try increasing the amount of dedicated memory for it in the BIOS.

I do have an intergrated card, but can I ask why and by how much? It’s not that I’m doubting the advice, but I’m genuinely curious as to how that works. I have 16 GB of RAM if that’ll help answer the second question (though fedora displays it as 15).

Do you have a dual GPU laptop? If so what is the second GPU. You can post the output of inxi -Fzx to answer that.

Some of the dual gpu laptops are configured to (by default) use the IGP for the laptop screen and the dGPU for the external monitor. Those sometimes give the type errors you are reporting because of switching between devices for the displays.

An analysis of the inxi output will let us make better analysis of what is happening and better suggestions for solution.

1 Like

inxi was not installed on my system, after installing and running, I got a bunch of text, I’ll paste it all since I can’t tell what’s important. My second GPU is an Nvidia one, sorry I forgot to mention that. Let me know if any other information will be helpful.

System:
  Kernel: 5.16.18-200.fc35.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-10.fc35 Desktop: GNOME v: 41.4
    Distro: Fedora release 35 (Thirty Five)
Machine:
  Type: Laptop System: Dell product: Dell G15 5515 v: 1.4.0
    serial: <superuser required>
  Mobo: Dell model: 00VT1V v: A00 serial: <superuser required> UEFI: Dell
    v: 1.4.0 date: 07/20/2021
Battery:
  ID-1: BAT1 charge: 82.7 Wh (98.2%) condition: 84.2/86.0 Wh (98.0%)
    volts: 13.3 min: 11.4 model: Simplo 0x46,0x39,0x35,0x41,0x0B,0x0A,0x000E
    status: charging
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325
    charge: 55% (should be ignored) status: discharging
CPU:
  Info: 8-core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 0 cache: L1: 512 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 1515 high: 3073 min/max: 1200/3200 boost: enabled
    cores: 1: 2982 2: 1197 3: 1337 4: 1195 5: 1198 6: 1195 7: 2032 8: 1197
    9: 1197 10: 1196 11: 1196 12: 1198 13: 3073 14: 1259 15: 1397 16: 1397
    bogomips: 102206
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: Dell
    driver: nvidia v: 510.60.02 bus-ID: 01:00.0
  Device-2: AMD Cezanne vendor: Dell driver: amdgpu v: kernel
    bus-ID: 05:00.0
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-4:4
  Display: x11 server: X.Org v: 1.20.14 driver: X: loaded: amdgpu,nvidia
    unloaded: fbdev,modesetting,nouveau,vesa gpu: amdgpu,nvidia,nvidia-nvswitch
    resolution: 1: 1920x1080~60Hz 2: 1920x1080~120Hz
  OpenGL:
    renderer: AMD RENOIR (DRM 3.44.0 5.16.18-200.fc35.x86_64 LLVM 13.0.0)
    v: 4.6 Mesa 21.3.8 direct render: Yes
Audio:
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Device-2: AMD Renoir Radeon High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 05:00.1
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Dell
    driver: snd_rn_pci_acp3x v: kernel bus-ID: 05:00.5
  Device-4: AMD Family 17h/19h HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 05:00.6
  Sound Server-1: ALSA v: k5.16.18-200.fc35.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.49 running: yes
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: Dell driver: r8169 v: kernel
    port: 2000 bus-ID: 03:00.0
  IF: enp3s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 vendor: Rivet Networks Killer™
    driver: iwlwifi v: kernel bus-ID: 04:00.0
  IF: wlp4s0 state: up mac: <filter>
  IF-ID-1: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A
    mac: <filter>
  IF-ID-2: proton0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IF-ID-3: pvpnksintrf0 state: unknown speed: N/A duplex: N/A mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-3:3
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 476.94 GiB used: 102.94 GiB (21.6%)
  ID-1: /dev/nvme0n1 model: OM3PDP3-AD NVMe KDI 512GB size: 476.94 GiB
    temp: 37.9 C
Partition:
  ID-1: / size: 475.14 GiB used: 102.64 GiB (21.6%) fs: btrfs dev: /dev/dm-0
    mapped: luks-51f4300d-e1b2-415e-8224-6c8226cfa5de
  ID-2: /boot size: 973.4 MiB used: 291.1 MiB (29.9%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 299.4 MiB used: 14 MiB (4.7%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 475.14 GiB used: 102.64 GiB (21.6%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-51f4300d-e1b2-415e-8224-6c8226cfa5de
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 52.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 441 Uptime: 36m Memory: 15.04 GiB used: 3.8 GiB (25.3%)
  Init: systemd runlevel: 5 Compilers: gcc: 11.2.1 Packages: 40
  note: see --pkg Shell: Bash v: 5.1.8 inxi: 3.3.14

I can’t seem to edit this again so I’ll reply to the original post, but I discovered something. From what I can see the issue now only affects flatpaks from flathub. Apps like videos and vivaldi which had the issue before no longer seem to have the issue. I wonder if it was a bug in some library that got patched?

EDIT: Nevermind, the issue simply fixed itself when I made the laptop monitor the primary monitor instead of my second external monitor being the primary monitor.

Ok, that is not an issue for failing to mention it, though having all the info can speed up solutions.

Have you followed these instructions from Howto/NVIDIA - RPM Fusion

NVIDIA PrimaryGPU Support
Using PrimaryGPU allows to use the NVIDIA driver by default instead of the iGPU. This is also required in order to use external display when internally connected from the NVIDIA hardware. Unfortunately, setting this option automatically when an external display is connected is not supported by NVIDIA at this time. To recover this previous behaviour, you can use:

cp -p /usr/share/X11/xorg.conf.d/nvidia.conf /etc/X11/xorg.conf.d/nvidia.conf
And edit the file to use: Option "PrimaryGPU" "yes"

I did that a long time back and have had no issues at all with switching between screens. I placed the recommended Option "PrimaryGPU" "yes" in both stanzas of the copied nvidia.conf file after it is placed it /etc/X11/xorg.conf.d/

Ok, I copied the file and made that edit, then rebooted. It seems to be fine now, even when the second monitor is set to the primary monitor. Thanks for the help!